Opened 9 years ago

Closed 9 years ago

#5024 closed defect (fixed)

FOTAQ : PSP won't load save game

Reported by: SF/albadross Owned by: bluddy
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

I am running Flight Of The Amazon Queen (English Freeware CD Version (mp3 compressed sfx/speech) version downloaded from the ScummVM site) in parallel on both a PC (1.2.0svn51206) and a PSP (1.2.0svn51342) at the same time.

But, while I can load all my savegames on the PC, I cannot load any of the ones on the PSP. They will not appear in the 'journal' as it is called in the game (or by using F5). Therefore I cannot reload them.

I did notice the savegame names from the PC were in lower case but the ones from the PSP were in upper case. I did of course check this was not the problem.

I have included a savegame from the PC version that works on the PC. I also found that the equivalent savegame from the PSP would not work on the PC.

Before submitting this bug, I did check whether it had been dealt with before and found the same bug in 2837732. That was claimed to be fixed and closed in August 2009. I didn't know how to re-open it so I have submitted the bug again as the problem is definitely re-occurring.

Ticket imported from: #3036170. Ticket imported from: bugs/5024.

Attachments (1)

queen.s01 (12.3 KB ) - added by SF/albadross 9 years ago.
Savegame from beginning of FOTAQ on the PC

Download all attachments as: .zip

Change History (5)

by SF/albadross, 9 years ago

Attachment: queen.s01 added

Savegame from beginning of FOTAQ on the PC

comment:1 by fingolfin, 9 years ago

Owner: set to bluddy

comment:2 by bluddy, 9 years ago

Resolution: fixed

comment:3 by bluddy, 9 years ago

Confirmed that the PSP can't play a Windows save. From my test, Windows *can* play a PSP save.

Turns out that the problem on the PSP is that it uses a Linux-style file system (with permissions etc). Making a file lower case in Windows doesn't seem to affect the way the PSP sees it -- it's still upper case. Queen checks for the letter 's' (lowercase) right after the '.' in the savefile name. I changed this to check for 'S' as well and the fix seems to work.

albadross, please confirm.

comment:4 by sev-, 9 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.