Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4988 closed defect (fixed)

HOYLE3 demo: Stuck in the intro

Reported by: SF/escarlate Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Hoyle's Book of Games 3

Description

The demo stops at the title screen, after a few text boxes. The music keeps playing, and the quit menu can still be invoked with a mouse click.

ScummVM Version: 1.2.0svn51349
Operating System: Win32 (XP SP2)

Ticket imported from: #3035242. Ticket imported from: bugs/4988.

Change History (6)

comment:1 by SF/mthreepwood, 9 years ago

This was working fairly recently, iirc... I'll bisect a bit later to find out where it broke.

comment:2 by sev-, 9 years ago

Component: Engine: SCI
Game: Hoyle's Book of Games 3

comment:3 by SF/mthreepwood, 9 years ago

Owner: set to m-kiewitz

comment:4 by SF/mthreepwood, 9 years ago

I got to bisect tonight. It seems the fix for the lsl1 casino door problem has broken this (r50921 - "SCI: solved lsl1 casino door, lsl6 tram disappearing and qfg1 vga gate issue - i hope this won't cause regressions, but calling the method in collision case is definitely wrong").

Assigning to m_kiewitz because it was his commit.

comment:5 by bluegr, 9 years ago

Owner: changed from m-kiewitz to bluegr
Resolution: fixed
Status: newclosed

comment:6 by bluegr, 9 years ago

Hoyle 3 bugs #3035077, #3035080, #3035081 and #3035242 are are caused by the same issue, the "completed" case removed in rev #50921 from inside kDoBresen(). Fixed in the latest SVN (rev #51479), thanks for reporting this

Note: See TracTickets for help on using tickets.