Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4982 closed defect (fixed)

Hoyle 3: Uninitialized read script error

Reported by: SF/ssburnout Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Hoyle's Book of Games 3

Description

Play dominoes.
You have to select 7 dominoes.
Click on a dominoe ( i picked 4th dominoe of 1st row). It will reveal its value and turn sideways.
Try to click on a second dominoe, nothing happens.
Click on that same first dominoe again.

ERROR: Uninitialized read for temp 504 from method char::say (script 0, localCall ffffffff)!

This is with rev 51344 on Hoyle 3 PC.

Ticket imported from: #3035080. Ticket imported from: bugs/4982.

Change History (4)

comment:1 by bluegr, 9 years ago

The crash is fixed now, but you still can't select any dominoes after selecting the first one

comment:2 by sev-, 9 years ago

Component: Engine: SCI
Game: Hoyle's Book of Games 3

comment:3 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:4 by bluegr, 9 years ago

Hoyle 3 bugs #3035077, #3035080, #3035081 and #3035242 are are caused by the same issue, the "completed" case removed in rev #50921 from inside kDoBresen(). Fixed in the latest SVN (rev #51479), thanks for reporting this

Note: See TracTickets for help on using tickets.