Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4981 closed defect (fixed)

Hoyle 3: Problems in checkers

Reported by: SF/ssburnout Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Hoyle's Book of Games 3

Description

Play checkers.
Try to play an invalid move, like move your pawn to a black square.
Notice that the pawn isn't moved back to its original position like it should, and the game may "freeze", ie the hand cursor appears. It has consistently done frozen for me on first or second invalid move attempt.

This is with rev 51344 and Hoyle 3 PC.

Ticket imported from: #3035077. Ticket imported from: bugs/4981.

Change History (3)

comment:1 by sev-, 9 years ago

Component: Engine: SCI
Game: Hoyle's Book of Games 3

comment:2 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:3 by bluegr, 9 years ago

Hoyle 3 bugs #3035077, #3035080, #3035081 and #3035242 are are caused by the same issue, the "completed" case removed in rev #50921 from inside kDoBresen(). Fixed in the latest SVN (rev #51479), thanks for reporting this

Note: See TracTickets for help on using tickets.