Opened 9 years ago

Closed 9 years ago

#4970 closed defect (fixed)

SCI: Music out of tune after loading a save

Reported by: SF/kuroshiro Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 5

Description

This bug seems to be pervasive across a few games in the engine. For me so far it has happened in both KQ5CD and Freddy Pharkas CD.

What happens is basically when a save is loaded, the music will be extremely out of tune (flat). Generally this will only happen when loading from the main menu, and is fixed when a new piece of music starts. It does not occur when loading a game into a room with the same music.

Ticket imported from: #3034974. Ticket imported from: bugs/4970.

Attachments (1)

kq5.003 (54.7 KB ) - added by SF/kuroshiro 9 years ago.
load this immediately, should reproduce the problem

Download all attachments as: .zip

Change History (5)

by SF/kuroshiro, 9 years ago

Attachment: kq5.003 added

load this immediately, should reproduce the problem

comment:1 by SF/kuroshiro, 9 years ago

Added a save game from KQ5CD that will usually reproduce this bug. Just say "Yes" to having played KQ5 and then immediately load the game. The music should be off, but will be fixed by going into any of the shops.

comment:2 by sev-, 9 years ago

Component: Engine: SCI
Game: King's Quest 5

comment:3 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:4 by bluegr, 9 years ago

Fixed in r55246

Note: See TracTickets for help on using tickets.