Opened 9 years ago

Closed 9 years ago

#4968 closed defect (fixed)

ECOQUEST/floppy: "no free channels"

Reported by: SF/graxer Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: EcoQuest 1

Description

Game: EcoQuest: The Search for Cetus
Game Version: Floppy/DOS/English
ScummVM Version: 1.2.0svn51274
Operating System: Windows 7

After you release Delphineus from Adam's house, and after the cutscene in which he returns, ScummVM crashes to the console.

Ticket imported from: #3034934. Ticket imported from: bugs/4968.

Change History (8)

comment:1 by m-kiewitz, 9 years ago

hi there,

please add the exact console message. If its an uninitialized error, please post the full console log (parameter x:) as well. Thanx.

comment:2 by SF/graxer, 9 years ago

"ERROR: no free channels!"

I'm not sure what an uninitialized error is though, or what you mean by "parameter x:".

comment:3 by m-kiewitz, 9 years ago

nevermind, no free channels is the sound system

comment:4 by sev-, 9 years ago

Component: Engine: SCI
Game: EcoQuest 1

comment:5 by m-kiewitz, 9 years ago

just to note:

this is caused by waves playing, then some music and then that music is faded out and another music is started during that phase. In Sierra SCI the waves seem to get stopped somehow when the first music starts. We don't so midi channels get exhausted.

comment:6 by m-kiewitz, 9 years ago

Summary: ECOQUEST: Game crashes near beginningECOQUEST/floppy: "no free channels"

comment:7 by m-kiewitz, 9 years ago

fixed in r51715

comment:8 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.