Opened 9 years ago

Closed 9 years ago

#4956 closed defect (fixed)

ECOQUEST: Object movement in intro

Reported by: SF/graxer Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: EcoQuest 1

Description

Game: EcoQuest: The Search for Cetus
Game Version: Floppy/DOS/English
ScummVM Version: 1.2.0svn51274
Operating System: Windows 7

During the introduction of EcoQuest, when Delphineus swims into the the net the net drifts jerkily upwards instead of slightly diagonally.

Ticket imported from: #3034584. Ticket imported from: bugs/4956.

Change History (11)

comment:1 by m-kiewitz, 9 years ago

hi there,

What do you mean exactly? the net motion before the dolphin is caught in it? Or afterwards? I don't see any real difference between our interpreter and sierras interpreter http://www.youtube.com/watch?v=GvCJiHj9P94

comment:2 by SF/graxer, 9 years ago

After he's in the net. I just tested it again and this time the net just flashed up to the top of the screen instead of drifting upwards.

comment:3 by sev-, 9 years ago

Component: Engine: SCI
Game: EcoQuest 1

comment:4 by SF/escarlate, 9 years ago

As of svn51774, it seems to play the same way, at least in the French version (the initial jiggling of the net is a bit faster on the original, though).

comment:5 by fingolfin, 9 years ago

So, does that mean the issue is resolved and can be closed? Graxer, can you please re-test?

comment:6 by SF/graxer, 9 years ago

This bug remains and it seems that it is inconsitant in the way it is shown. I just tried it a few times; the first and fourth times it jolted to the right a bit then drifted upwards, the second and third times it jolted to the right slightly then jolted all the way up. I recorded both examples and they can be seen at these two links:

http://img812.imageshack.us/i/clip0004.mp4/

http://img689.imageshack.us/i/clip0007i.mp4/

comment:7 by m-kiewitz, 9 years ago

probably it's now fixed in r52467, please check

comment:8 by SF/graxer, 9 years ago

The intro now crashes before it reaches the point in question. I have reported this bug here: https://sourceforge.net/tracker/?group_id=37116&atid=418820

comment:9 by SF/graxer, 9 years ago

Sorry, the last link wasn't complete for some reason https://sourceforge.net/tracker/?func=detail&aid=3057820&group_id=37116&atid=418820

comment:10 by SF/graxer, 9 years ago

This issue appears to have been solved now as you say. Thanks!

comment:11 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.