Opened 9 years ago

Closed 9 years ago

Last modified 2 years ago

#4952 closed defect (fixed)

SCI: PQ2 Demo: Non-existant view

Reported by: SF/mthreepwood Owned by: OmerMor
Priority: low Component: Engine: SCI
Keywords: original Cc:
Game: Police Quest 2

Description

PQ2 Demo (r51294, Mac OS X, 64-bit)

If you watch the demo for a while (to the scene in the police station), the game errors out with "view resource 6 not found!"

Ticket imported from: #3034543. Ticket imported from: bugs/4952.

Change History (13)

comment:1 by SF/mthreepwood, 9 years ago

It seems the resource volume may be corrupted a bit here. Views 6, 7, 10, 13, 14, 15, and 16 aren't in the file, but all the rest after (starting with view 20 at offset 0xfb03) are there.

comment:2 by SF/mthreepwood, 9 years ago

For what it's worth, in DOSBox, the game goes no further but continues to play music.

comment:3 by m-kiewitz, 9 years ago

The demo seems to be broken. In Dos-Box music plays further, but it stutters a lot and the whole engine goes mad. I don't consider this as a bug per se. We should better try to find the original demo.

comment:4 by SF/mthreepwood, 9 years ago

Agreed. I'll try to contact the guys over at Sierra Help (where this demo is originally from) to see if they have the original version. The one on their site is broken too.

comment:5 by sev-, 9 years ago

Component: Engine: SCI
Game: Police Quest 2

comment:6 by OmerMor, 9 years ago

I managed to "fix" the police quest 2 demo.
The current one had a broken resource.001 file.
In this file, views {4,6,7,10,13,14,15} were corrupt.
I dumped the appropriate views from the real game to the game folder and now the demo works fine.
From the size of the views and their context in the demo I noticed that all but one (view.010) of the views match exactly to the the real game.
View #10 was apparently made just for this demo and is probably showing Bonds walking with his pistol by his side. I replaced this view with view #0 which shows bonds walking w/o a pistol. The view is used in the last scene in the demo where Bonds & Bains walk toward each other. The scene looks fine with view #0 as well so it's not so bad. I guess a recreated view could be drawn by hand.
The fixed demo can be found here:
http://hotfile.com/dl/63607950/adcdc46/pq2-dos-ni-demo-en.zip.html

Now the demo works fine in scummvm.

comment:7 by SF/mthreepwood, 9 years ago

However, you ripped those sprites from the full game. I wouldn't be comfortable distributing this. In any case, I asked over at Sierra Help and they are tracking the non-corrupted version down.

comment:8 by bluegr, 9 years ago

Priority: normallow

comment:9 by bluegr, 9 years ago

Reducing the priority of this one, since it's caused by corrupt data

comment:10 by bluegr, 9 years ago

Keywords: original added
Owner: set to bluegr
Status: newclosed

comment:11 by bluegr, 9 years ago

Moved to the known SCI bugs page:
http://wiki.scummvm.org/index.php/SCI/Bugs

comment:12 by m-kiewitz, 4 years ago

Summary: PQ2 Demo: Non-existant viewSCI: PQ2 Demo: Non-existant view

comment:13 by OmerMor, 2 years ago

Owner: changed from bluegr to OmerMor
Resolution: fixed

I found a working version of this demo last year, and it's already hosted by ScummVm.

Marking as fixed.

Note: See TracTickets for help on using tickets.