Opened 9 years ago

Closed 9 years ago

Last modified 14 months ago

#4915 closed defect (fixed)

GUI: GMM errors out in Hercules mode

Reported by: lordhoto Owned by: sev-
Priority: normal Component: GUI
Keywords: Cc:
Game: Maniac Mansion

Description

ScummVM trunk r50638 Linux/amd64 g++ (Debian 4.4.4-6) 4.4.4

When opening up the GMM in Maniac with Hercules graphics mode, I get the following error, when using the classic theme:: Widget <GlobalMenu.Quit> has y + h > 350 (366)!

And the following one, when using the modern theme: Widget <GlobalMenu> has y < 0 (-4)!

Ticket imported from: #3024930. Ticket imported from: bugs/4915.

Change History (6)

comment:1 by fingolfin, 9 years ago

Assigning this to Eugene, since IIRC he wrote the hercules etc. support.

We keep having issues with the layout of the launcher / GMM / options dialog. I wonder whether the current GSoC testing work could be extended to test those at various resolutions? 320x200 (!), 320x240, hercules, ... ? We should at the very least document somewhere on the Wiki (maybe under HOWTO-Release") which dialogs must be tested at which resolutions before every release.

comment:2 by fingolfin, 9 years ago

Owner: set to sev-

comment:3 by sev-, 9 years ago

Resolution: fixed
Status: newclosed

comment:4 by sev-, 9 years ago

Fixed in SVN by switching Hercules resolutions to lowres GUI

comment:5 by lordhoto, 9 years ago

I can confirm that it is working now. Thanks for that. Too bad we couldn't use the hi-res theme, since now we won't have any thumbnail display support anymore, which we had in the past, but well shouldn't be that much of an issue.

comment:6 by digitall, 14 months ago

Component: GUI
Game: Maniac Mansion
Note: See TracTickets for help on using tickets.