Opened 9 years ago

Closed 9 years ago

Last modified 11 months ago

#4912 closed defect (fixed)

KQ6 - Crashes when attempting to save

Reported by: SF/aroenai Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 6

Description

Using Windows 7 x64 1.2.0svn50531 from downloads page.

King's Quest 6 CD/Win crashes when clicking on save after typing a name, no error messages given.
King's Quest 6 floppy crashes when the selecting the options menu with "ERROR: Uninitialized read for temp 4 from method controlWin:open (script 903, localCall ffffffff)!"

Ticket imported from: #3023602. Ticket imported from: bugs/4912.

Change History (6)

comment:1 by bluegr, 9 years ago

Hello

The error in KQ6 floppy has been fixed in the next daily version.
I couldn't replicate the error in KQ6 CD.... can you check if it happens for you again?

comment:2 by bluegr, 9 years ago

It just occurred to me... are you trying the Windows or DOS Version of KQ6CD? The Windows (i.e. hires) version is still problematic when saving (the screen size is odd and that confuses the code that creates the screen thumbnail), try the DOS one

comment:3 by bluegr, 9 years ago

The Windows version of KQ6 CD shouldn't crash anymore while saving, please verify that you no longer get crashes please

comment:4 by SF/aroenai, 9 years ago

Yeah sorry, I was playing the windows version, but I thought I had tried it with the cd dos version and it did the same thing before, anyway the problem is fixed thank you ;)

comment:5 by m-kiewitz, 9 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:6 by digitall, 11 months ago

Component: Engine: SCI
Game: King's Quest 6
Note: See TracTickets for help on using tickets.