Opened 9 years ago

Closed 8 years ago

#4898 closed defect (fixed)

WAXWORKS: Tomb visitors check in, they don't check out

Reported by: SF/marecki Owned by: Kirben
Priority: high Component: Engine: AGOS
Keywords: Cc:
Game: Waxworks

Description

Hello,

In other words, I've just run into a rather interesting situation when I am able to enter the ancestors' tomb but cannot leave, as the game claim there are no paths to take from there. The problem persists over reloading the save game, with and without restarting ScummVM. Attaching a save game from right in front of the crypt.

Details:
- ScummVM version: 1.1.1 (it seems all the commits in engines/agos since that release have been related to other things so I haven't tried the daily build yet)
- game version: DOS/floppy
- game language: English
- platform: Linux/x86, gcc-4.3.4

Ticket imported from: #3011646. Ticket imported from: bugs/4898.

Attachments (1)

waxworks-pc.006 (3.5 KB ) - added by SF/marecki 9 years ago.

Download all attachments as: .zip

Change History (9)

by SF/marecki, 9 years ago

Attachment: waxworks-pc.006 added

comment:1 by jvprat, 9 years ago

Owner: set to Kirben

comment:2 by sev-, 9 years ago

Priority: normalhigh

comment:3 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:4 by Kirben, 8 years ago

I just added fix to ScummVM Git which should hopefully solve these load/save issues, please try the next daily snapshot of ScummVM.

comment:5 by bluegr, 8 years ago

There hasn't been any feedback on this for 4 months now. This bug seems to have the same root cause as the 3 other bugs that have been submitted regarding Waxworks saves:
bugs #3378910, #3011646, #3011639, #3011635

All of these bugs have been fixed by kirben on the 27th of August (commit #5e174cbf), a fix which is included in ScummVM 1.4.0.

Since there hasn't been any feedback on this for over 4 months, it is assumed that this bug has already been fixed, thus, I'm setting this bug to pending. If you're still having issues, please reply.

comment:6 by bluegr, 8 years ago

Resolution: fixed
Status: newpending

comment:7 by bluegr, 8 years ago

Status: pendingclosed

comment:8 by bluegr, 8 years ago

There has been no feedback on this for over 7 months, so this is considered fixed now. Changing status from "Pending" to "Closed" (which should have been done automatically, but for some reason it hasn't)

Note: See TracTickets for help on using tickets.