Opened 9 years ago

Closed 8 years ago

#4897 closed defect (fixed)

WAXWORKS: Doors remain open after loading earlier save game

Reported by: SF/marecki Owned by: Kirben
Priority: high Component: Engine: AGOS
Keywords: Cc:
Game: Waxworks

Description

Hello,

It appears ScummVM doesn't entirely clean its game-status memory upon loading a save game, at least in London: upon loading an older save inside that waxwork WITHOUT quitting Waxworks, doors opened between saving and restoring remain opened. To reproduce:
- save the game before entering the chemist's;
- unlock and open the chemist's back door;
- load the saved game and have a look at the door in question.
I have also seen the same happen to the door at the bottom of the stairs at Molly's place. Whether this happens in other waxworks as well remains to be tested.

Details:
- ScummVM version: 1.1.1 (it seems all the commits in engines/agos since that release have been related to other things so I haven't tried the daily build yet)
- game version: DOS/floppy
- game language: English
- platform: Linux/x86, gcc-4.3.4

Ticket imported from: #3011639. Ticket imported from: bugs/4897.

Attachments (1)

waxworks-pc.002 (3.5 KB ) - added by SF/marecki 9 years ago.
Cemetery, in front of the church door. Open the door and reload.

Download all attachments as: .zip

Change History (14)

comment:1 by SF/marecki, 9 years ago

I have just confirmed this also happens to the church door at the cemetery (see the enclosed save game), changing the summary accordingly.

comment:2 by SF/marecki, 9 years ago

Summary: London doors remain open after loading an earlier save gameDoors remain open after loading an earlier save game

by SF/marecki, 9 years ago

Attachment: waxworks-pc.002 added

Cemetery, in front of the church door. Open the door and reload.

comment:3 by jvprat, 9 years ago

Owner: set to Kirben
Summary: Doors remain open after loading an earlier save gameLondon doors remain open after loading an earlier save game

comment:4 by jvprat, 9 years ago

Summary: London doors remain open after loading an earlier save gameWAXWORKS: Doors remain open after loading earlier save game

comment:5 by SF/marecki, 9 years ago

Hmm, turns out the door in question remains open even after RESTARTING ScummVM... Weird! It's only "half-open" though, that is if you enter the church and turn around it will be closed.

comment:6 by SF/marecki, 9 years ago

It appears other aspects of the game exhibit the same behaviour. Here is how I have just bypassed the muggers near the waterfront in London:
- accidentally walked into the ambush and got mugged;
- loaded the save game from right after receiving the crowbar;
- noted both alleys to be devoid of muggers and proceeded without having to blow the whistle.

Moreover, now that I encountered the "can't leave the tomb" bug (3011646) it happens every time I reach that point in the game, ever after restarting ScummVM.

comment:7 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:8 by sev-, 9 years ago

Priority: normalhigh

comment:9 by Kirben, 8 years ago

I just added fix to ScummVM Git which should hopefully solve these load/save issues, please try the next daily snapshot of ScummVM.

comment:10 by bluegr, 8 years ago

There hasn't been any feedback on this for 4 months now. This bug seems to have the same root cause as the 3 other bugs that have been submitted regarding Waxworks saves:
bugs #3378910, #3011646, #3011639, #3011635

All of these bugs have been fixed by kirben on the 27th of August (commit #5e174cbf), a fix which is included in ScummVM 1.4.0.

Since there hasn't been any feedback on this for over 4 months, it is assumed that this bug has already been fixed, thus, I'm setting this bug to pending. If you're still having issues, please reply.

comment:11 by bluegr, 8 years ago

Resolution: fixed
Status: newpending

comment:12 by bluegr, 8 years ago

Status: pendingclosed

comment:13 by bluegr, 8 years ago

There has been no feedback on this for over 7 months, so this is considered fixed now. Changing status from "Pending" to "Closed" (which should have been done automatically, but for some reason it hasn't)

Note: See TracTickets for help on using tickets.