Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#4895 closed defect (fixed)

WAXWORKS: Save games don't track completed waxworks

Reported by: SF/marecki Owned by: Kirben
Priority: high Component: Engine: AGOS
Keywords: Cc:
Game: Waxworks

Description

Hello,

It seems the Waxworks save games do not contain information on whether a certain waxwork has been completed or not... During my recent play-through I visited the pyramid, the graveyard, the mine and London, in that order; after leaving the last one I was surprised to see that the witch one didn't become available, the assistant kept telling me to hurry as before and all but the last waxwork I'd visited being accessible once again. Moreover, after restarting ScummVM and reloading the save I'd made right after exiting London (attached here) I became able to re-enter that one as well, even though I am absolutely certain the curtains WERE drawn on that one when I saved the game.

Details:
- ScummVM version: 1.1.1 (it seems all the commits in engines/agos since that release have been related to other things so I haven't tried the daily build yet)
- game version: DOS/floppy
- game language: English
- platform: Linux/x86, gcc-4.3.4

Ticket imported from: #3011635. Ticket imported from: bugs/4895.

Attachments (2)

waxworks-pc.005 (3.6 KB ) - added by SF/marecki 9 years ago.
A save file after completing four waxworks
waxworks-pc.001 (3.7 KB ) - added by SF/marecki 9 years ago.
Got the anti-witch items... but the waxwork is closed

Download all attachments as: .zip

Change History (12)

by SF/marecki, 9 years ago

Attachment: waxworks-pc.005 added

A save file after completing four waxworks

comment:1 by jvprat, 9 years ago

Owner: set to Kirben
Summary: Save games don't track completed waxworksWAXWORKS: Save games don't track completed waxworks

comment:2 by SF/marecki, 9 years ago

Managed to complete both London and the cemetery without reloading, afterwards both waxworks were curtained off like they should. Tried to carry on but stupidly walked into a pod at the mine. Reloaded a saved game from the beginning of that waxwork and finished it... to see all three curtained off. Maybe the non-tracking problem pertains specifically to saves from the hub area...

comment:3 by SF/marecki, 9 years ago

Okay, I think I've figured this out. You can save and load your game as often as and wherever you want, as long as you don't quit the game! In other words:
- save games do not track the state of any of the five waxworks (with potentially interesting results - attached you will find a save created right before entering the witch waxwork, which when I load it in a fresh session of ScummVM has that waxwork closed and the other four open despite me having the four special items in my inventory), which is obviously a bug;
- the engine tracks their state in memory, which may in fact be a bug (or more specifically, another aspect of the problem from my "doors remain open" report) as well - it would be an interesting exercise to complete several waxworks in one go, then load an early save game and see how many remain closed.

On a different note, I am happy to say that as of ScummVM version at least 1.1.1, Waxworks can in fact be finished.

by SF/marecki, 9 years ago

Attachment: waxworks-pc.001 added

Got the anti-witch items... but the waxwork is closed

comment:4 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:5 by sev-, 9 years ago

Priority: normalhigh

comment:6 by Kirben, 8 years ago

I just added fix to ScummVM Git which should hopefully solve these load/save issues, please try the next daily snapshot of ScummVM.

comment:7 by bluegr, 8 years ago

Resolution: fixed
Status: newpending

comment:8 by bluegr, 8 years ago

There hasn't been any feedback on this for 4 months now. This bug seems to have the same root cause as the 3 other bugs that have been submitted regarding Waxworks saves:
bugs #3378910, #3011646, #3011639, #3011635

All of these bugs have been fixed by kirben on the 27th of August (commit #5e174cbf), a fix which is included in ScummVM 1.4.0.

Since there hasn't been any feedback on this for over 4 months, it is assumed that this bug has already been fixed, thus, I'm setting this bug to pending. If you're still having issues, please reply.

comment:9 by bluegr, 8 years ago

There has been no feedback on this for over 7 months, so this is considered fixed now. Changing status from "Pending" to "Closed" (which should have been done automatically, but for some reason it hasn't)

comment:10 by bluegr, 8 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.