Opened 9 years ago

Closed 9 years ago

#4891 closed defect (fixed)

LURE: Goewin stuck at the counter

Reported by: SF/ilguido Owned by: dreammaster
Priority: high Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

Goewin, Gereint and Luther are all stuck at the counter. After exiting the weregate, I walked a bit and Goewin got to the Severed Arms on its own.

Scummvm 1.1.1 Linux. Italian version of Lure.

(In a previous savegame I got Goewin stuck in the weregate: just after exiting the weregate, she stood on the gate and when it closed, she got stuck)

Ticket imported from: #3008511. Ticket imported from: bugs/4891.

Attachments (1)

lure.001 (22.9 KB ) - added by SF/ilguido 9 years ago.
savegame

Download all attachments as: .zip

Change History (8)

by SF/ilguido, 9 years ago

Attachment: lure.001 added

savegame

comment:1 by SF/ilguido, 9 years ago

Summary: Goewin stuck at the counterLURE: Goewin stuck at the counter

comment:2 by dreammaster, 9 years ago

Owner: set to dreammaster

comment:3 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:4 by sev-, 9 years ago

Priority: normalhigh

comment:5 by dreammaster, 9 years ago

Okay, I fixed the problem with Goewin getting stuck in the Weregate - the script that closed the door wasn't actually checking to see if the doorway was blocked. I added a workaround to check for being blocked, and if so, keep deferring executing the script until it's unblocked.

The other problem, stuck at counter, is going to be harder to figure out, since it's already happened in the savegame; so I'm not sure how to identify the cause.

comment:6 by dreammaster, 9 years ago

I'm fairly confident I've found the cause of the error; it was the same section of code as in bug #3060480 - the code for returning a follower to the player when their exiting from a room is blocked. The game thought she was still a follower, so cleared her schedule and returned her to the player.. and thereafter she no longer had a schedule.

Note that this won't fix the problem savegame, since the schedule has already been lost, but should prevent it from happening again.

comment:7 by dreammaster, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.