Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4884 closed defect (fixed)

FF: Crackling/static popping

Reported by: SF/dpb23 Owned by: eriktorbjorn
Priority: high Component: Engine: AGOS
Keywords: Cc:
Game: The Feeble Files

Description

As of version 1.1 and the latest daily build there's an intermittent popping noise in the background audio that shouldn't be there. If it isn't immediately noticeable the easiest way to reproduce it is to start a new game, skip through all the opening videos, enter the door, use the message screen and skip through the dialogue with right-click, then go back outside again.

I tested 0.13 and 1.0 and they don't have this issue.

4CD/Windows/English
Win32

Ticket imported from: #3000876. Ticket imported from: bugs/4884.

Change History (6)

comment:1 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:2 by sev-, 9 years ago

Owner: set to Kirben
Priority: normalhigh

comment:3 by eriktorbjorn, 9 years ago

Could you check if this still happens? I just made a fix which I hope is the problem you were hearing. The playSoundData() function forgot to count the first eight bytes as part of the size of a WAV stream.

comment:4 by SF/dpb23, 9 years ago

I just tried out the newest build and it seems to be working fine now. Thanks for the fix!

comment:5 by eriktorbjorn, 9 years ago

Great! Thanks for testing it.

comment:6 by eriktorbjorn, 9 years ago

Owner: changed from Kirben to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.