Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#488 closed defect (fixed)

FOA: Music dies after Intro

Reported by: SF/trinity78 Owned by: SF/jamieson630
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Win2k Adv. Server + SDL Backend

Using latest daily build (also happend with older build).

The music in the scene where Indy opens the statue
with a key (with Marcus and Kerner in the same room,
afterwards Kerner escapes through the window) is
missing if you do NOT skip the intro.
If you skip the intro the music plays fine.

This is similar to bug #565933 .

Ticket imported from: #622606. Ticket imported from: bugs/488.

Change History (7)

comment:1 by SF/ender, 17 years ago

This one is yours :)

Reassigning.

comment:2 by SF/ender, 17 years ago

Owner: set to SF/jamieson630

comment:3 by SF/jamieson630, 17 years ago

Bug occurs as far back as September 24. I'm going to
consider this secondary to Sam & Max iMuse issues. As
time permits, though, I'll keep poking to see if I can find
exactly what far-back change broke this. (It worked in the
0.2.0 release.)

comment:4 by SF/jamieson630, 17 years ago

The latest CVS build (imuse.cpp version 1.64) should correct
this problem. Patch #607175 created this regression. I've
fixed the regression, and hopefully have preserved the goal of
607175 using start_sound instead of get_sound_status.

Ender, as a newbie developer, I'm hesistant to close this
myself. Can you confirm the fix and do the honors? :)

comment:5 by SF/jamieson630, 17 years ago

Resolution: fixed

comment:6 by SF/ender, 17 years ago

Fixed.

Closed.

Thhhhhhhat's all folks!

comment:7 by SF/ender, 17 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.