Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#4842 closed defect (duplicate)

RTZ: Stall / Audio Loop after not playing a "few" hours

Reported by: sunmax Owned by: bluegr
Priority: normal Component: Engine: MADE
Keywords: Cc:
Game: Return to Zork

Description

Using branch 1.1.0 (pre 48413)

Both on PS2 and low-end PC (800 Mhz, 512 MB) SDL backends.

Leave the game running at the beginning after the intro where
the vultures are flying in the sky - after couple of hours
(you gotta be patient), the games will stall with the sound
looping and a ton of the following being printed out:

WARNING: AdLib: Unknown control change message 117 (100)!
WARNING: AdLib: Unknown control change message 117 (100)!
WARNING: AdLib: Unknown control change message 117 (100)!

This seems awesomely similar to the following bugs:

# 2797283 DW: Noise after not playing a "few" hours

# 2948281 ITE: MidiParser::hangingNote(): Exceeded polyphony!

In all of 3 the audio goes bananas after some time of lack
of interaction from the user (maybe Aunt Jessie called, or
your gf just showed up ;-) - maybe they are unrelated, but
might be worthy investigating.

Thanks!
-max

Ticket imported from: #2979691. Ticket imported from: bugs/4842.

Change History (7)

comment:1 Changed 8 years ago by bluegr

Owner: changed from johndoe123 to bluegr

comment:2 Changed 8 years ago by bluegr

This issue has probably been fixed with r55256, can you please check if it
still occurs?

comment:3 Changed 8 years ago by bluegr

Resolution: fixed
Status: newpending

comment:4 Changed 8 years ago by bluegr

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:5 Changed 8 years ago by bluegr

Closing as duplicate of bug #2797283. This is a problem of the MIDI backend, not a problem in the game engine. For more information, please refer to that bug report

comment:6 Changed 8 years ago by bluegr

Resolution: fixedduplicate
Status: pendingclosed

comment:7 Changed 8 years ago by sunmax

Tried on both vintage PII (350 Mhz) [SDL backend] and PS2 backend, and I cannot reproduce it anymore after 12 hours, so I can confirm it's fixed ;-)

Note: See TracTickets for help on using tickets.