Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4840 closed defect (fixed)

NIPPON: Crash at character introduction (regression)

Reported by: raziel- Owned by: Kirben
Priority: high Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

ScummVM 1.2.0svn48423 (Mar 30 2010 09:02:12)
Features compiled in: Vorbis FLAC MP3 RGB zLib

After one has choosen which charcter to play there is a that animation of the chosen character (A little description and the mug shot getting bigger.

Now if i click anywhere on this screen the game crashes
I have at least one other occurance of this crash (with Donna in duisguise nearly at the end entering a new screen and clicking before the scene has completely loaded) but that one wasn't reproduceable.
This one is, every time

Nippon Safes Inc. (Amiga/Multilingual)

AmigaOS4
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #2979193. Ticket imported from: bugs/4840.

Attachments (2)

Crashlog_scummvm_2010-03-30_09-37-30.txt (32.3 KB) - added by raziel- 9 years ago.
Crash at character introduction
Crashlog_scummvm_2010-03-30_11-05-39.txt (32.4 KB) - added by raziel- 9 years ago.
Another instance (i think) while walking with Donna

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by raziel-

Crash at character introduction

Changed 9 years ago by raziel-

Another instance (i think) while walking with Donna

comment:1 Changed 9 years ago by fingolfin

Owner: set to peres

comment:2 Changed 9 years ago by Kirben

Another regression, which occurred between ScummVM 0.12.0 and ScummVM
0.13.0.

comment:3 Changed 9 years ago by Kirben

Priority: normalhigh

comment:4 Changed 9 years ago by Kirben

This regression was specifically caused by revision 33270.

comment:5 Changed 9 years ago by Kirben

Owner: changed from peres to Kirben
Resolution: fixed
Status: newclosed

comment:6 Changed 9 years ago by Kirben

Fixed in ScummVM SVN (branch and trunk), by restoring the code for kEngineBlockInput engine flag.

comment:7 Changed 9 years ago by Kirben

Summary: NIPPON: Crash at character introductionNIPPON: Crash at character introduction (regression)
Note: See TracTickets for help on using tickets.