Opened 9 years ago

Last modified 7 years ago

#4821 new defect

NIPPON: "Push the button" verb appears when it shouldn't

Reported by: raziel- Owned by: peres
Priority: normal Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

ScummVM 1.2.0svn48243 (Mar 12 2010 07:44:55)
Features compiled in: Vorbis FLAC MP3 RGB zLib

Path: Dino

Right at the beginning in the museum ego has to press buttons to open the caveau up at the first level
The buttons however don't change their color to red when pressed, they stay at green regardless the times one press.

This makes it impossible to proceed

Nippon Safes Inc. (Multi-lingual/Amiga)

Amiga OS4
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #2970532. Ticket imported from: bugs/4821.

Change History (15)

comment:1 Changed 9 years ago by jvprat

Owner: set to peres

comment:2 Changed 9 years ago by Kirben

I'm unable to reproduce the problem, when using ScummVM SVN under Windows XP.

Are you sure you are clicking on the right spot? I noticed the color only changes, when I click inside the colored section of each button.

comment:3 Changed 9 years ago by raziel-

Yes, 100% sure

It doesn't matter where i click (inside the button, slightly outside, as soon as the command "push the button" comes up), it doesn't change the color and it seems the scripts doesn't change the state either because i tried clicking the right buttons (in the blind)
RED GREEN
RED RED
and the caveat up on level doesn't open

comment:4 Changed 8 years ago by peres

I cannot reproduce the bug (on macos x). The buttons switch between red and green, and once the correct pattern is formed the caveau opens.

comment:5 Changed 8 years ago by peres

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:6 Changed 8 years ago by peres

Resolution: worksforme
Status: newpending

comment:7 Changed 8 years ago by raziel-

Yes, trying with the latest build the glitch is gone and everything works again

Though i wanted to ask something
The first (leftmost) icon in the command list is supposed to be the "open" icon, right?
Because if i use open on the panel (while it's still closed i get "Push the button" (remember the panel is still closed) and i cannot open the panel. I have to use the (third from left) "pick up" icon to remove the panel to get to see the buttons.

Not related me thinks, but maybe because now it "seems" the misbehaviour i had switched? :-)

Do you need me to add a new item for this?

comment:8 Changed 8 years ago by peres

Resolution: worksforme

comment:9 Changed 8 years ago by peres

After you PICKUP the fire extinguisher, you have to PICKUP the panel as well. It is scripted as a GET action, not OPEN.

If I hover on the panel with the OPEN action selected I see the 'push the button' message you are talking about, but it doesn't appear if I hover the cursor without an action. This might be a script bug or an engine bug: it would be ideal if you could test with the original.

comment:10 Changed 8 years ago by raziel-

Tested with the original interpreter and there is nothing displayed when i have OPEN selected (no "panel", no "button").
After i switched to selecting PICKUP the "panel" becomes a displayed name again

Thank you

comment:11 Changed 8 years ago by raziel-

Status: pendingnew

comment:12 Changed 7 years ago by digitall

OK.. Tested with Nippon Safes (Amiga) and:
ScummVM 1.4.0git1802-g0382e99-dirty (Aug 25 2011 01:50:57)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora AAC

To confirm, the originally reported bug with the Musuem Caveau control panel is still fixed, but the secondary issue i.e. That with the Open command selected, "Push The Button" appears when hovering the mouse over that area, even when you have not yet picked up the Fire Extinguisher and Panel.

Since from raziel_'s report, this doesn't occur in the original, this sounds like a priority / layer issue with that hotspot zone..

comment:13 Changed 7 years ago by bluegr

Summary: NIPPON: Button color stays always greenNIPPON: "Push the button" verb appears when it shouldn't

comment:14 Changed 7 years ago by bluegr

Updated description to reflect the current bug

comment:15 Changed 7 years ago by bluegr

Note: the current bug is not a show stopper, and it's mostly a presentation problem

Note: See TracTickets for help on using tickets.