Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4819 closed defect (fixed)

DRASCULA: missing german translation

Reported by: SF/windlepoons Owned by: eriktorbjorn
Priority: normal Component: Engine: Drascula
Keywords: Cc:
Game: Drascula

Description

- Missing few german translations of place names and actors
- Ask to Drunkard are not translated (english text).
No Problem with ScummVM release 1.0.0.

And the first image in the inventory has no verb (look, mirar, schau, regardez, guarda)

Game version: DOS/German (download from scummvm.org)
ScummVM 1.2.0svn48254 (Mar 14 2010 03:31:28)
Linux x86_32 (sidux 2.6.33)

Ticket imported from: #2970211. Ticket imported from: bugs/4819.

Attachments (1)

drascula-lang.diff (2.7 KB) - added by eriktorbjorn 9 years ago.
Patch against current SVN

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by fingolfin

Does "No Problem with ScummVM release 1.0.0" mean that it works with 1.0.0, but does not with current SVN? I.e. that this is a regression?

comment:2 Changed 9 years ago by fingolfin

Summary: Drascula: missing german translationDRASCULA: missing german translation

comment:3 Changed 9 years ago by SF/windlepoons

Yes, this is a regression.

with ScummVM 1.0.0 (Nov 8 2009 11:33:46) german translation works fine.
but not with ScummVM 1.1.0pre48347 (Mar 21 2010 09:07:46) or current svn build.

comment:4 Changed 9 years ago by eriktorbjorn

If I understand it correctly, the German version of Drascula registers two resource files with the archive manager: package.001 and package.003. I'm guessing that package.001 contains all the resources that aren't tied to any specific language, and some English ones for good measure, while package.003 contains the German ones which, when available, should override the ones in package.001.

But since package.001 is added first to the search manager, it gets a higher priority than package.003. We could either change the order of the file names in detection.cpp or (I like this better) use the optional priority parameter. The detector already has an optional "fileType" entry which could be (ab)used for this.

Based on these guesses, I'm attaching a possible patch.

Changed 9 years ago by eriktorbjorn

Attachment: drascula-lang.diff added

Patch against current SVN

comment:5 Changed 9 years ago by eriktorbjorn

I've committed my fix, after a brief discussion with Fingolfin to make sure I wasn't doing something obviously silly.

comment:6 Changed 9 years ago by eriktorbjorn

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.