Opened 9 years ago

Closed 9 years ago

#4818 closed defect (fixed)

NIPPON: Crash at end of the game (regression)

Reported by: raziel- Owned by: Kirben
Priority: normal Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

ScummVM 1.2.0svn48243 (Mar 12 2010 07:44:55)
Features compiled in: Vorbis FLAC MP3 RGB zLib

Path: Donna

When the game finishes and Donna is being kidnapped the game crashes

No save file due to bug #2969234

Nippon Safes Inc. (Multi-lingual/Amiga)

Amiga OS4
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #2970141. Ticket imported from: bugs/4818.

Attachments (3)

Crashlog_scummvm_2010-03-14_09-12-41.txt (28.9 KB) - added by raziel- 9 years ago.
GrimReaper log
nippon.012 (358 bytes) - added by raziel- 9 years ago.
walk outside, no crash, but a lockup
Crashlog_scummvm_2010-04-01_17-29-42.txt (33.0 KB) - added by raziel- 9 years ago.

Download all attachments as: .zip

Change History (13)

Changed 9 years ago by raziel-

GrimReaper log

comment:1 Changed 9 years ago by jvprat

Owner: set to peres

comment:2 Changed 9 years ago by Kirben

Does this problem still occur? just wondering if it might have been another sound sound looping related crash (like bug #2969211), which was fixed

Changed 9 years ago by raziel-

Attachment: nippon.012 added

walk outside, no crash, but a lockup

comment:3 Changed 9 years ago by raziel-

The crash doesn't occur anymore instead the game locks up with a black screen after the final graphic was shown

comment:4 Changed 9 years ago by Kirben

I'm unable to reproduce the lockup, with the attached saved game, when using ScummVM SVN under Windows XP.

Changed 9 years ago by raziel-

comment:5 Changed 9 years ago by raziel-

Seems i shout to early

I still get a crash after Donna walks out

Crashlog attached

comment:6 Changed 9 years ago by wjp

In CommandExec::runList(), the command list is deleted (from Location::cleanup called indirectly from _c_finito) while it's being iterated

comment:7 Changed 9 years ago by Kirben

This is another regression, which was specifically caused by revision 34939.

comment:8 Changed 9 years ago by Kirben

Summary: NIPPON: Crash at end of the gameNIPPON: Crash at end of the game (regression)

comment:9 Changed 9 years ago by Kirben

Fixed in ScummVM SVN (branch and trunk), by reverting part of the changes to Parallaction_ns::cleanupGame() in revision 34939.

Using freeLocation() in Parallaction_ns::cleanupGame() meant too many game variables were been cleared.

comment:10 Changed 9 years ago by Kirben

Owner: changed from peres to Kirben
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.