Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#4817 closed defect (fixed)

NIPPON: Disguise changing back and forth

Reported by: raziel- Owned by: bluegr
Priority: normal Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

ScummVM 1.2.0svn48243 (Mar 12 2010 07:44:55)
Features compiled in: Vorbis FLAC MP3 RGB zLib

Path: Donna

After escaping the mansion Donna looses her disguise and should look like normal (wavy brown hair) alas she is displayed only a second like this. After that she immidiately turns back into her disguise and stays like this.

Another occurence is when she kisses Dough a second time, she changes back to brown hair and afterwards to her disguise

Nippon Safes Inc. (Multi-lingual/Amiga)

Amiga OS4
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #2969915. Ticket imported from: bugs/4817.

Attachments (2)

nippon.006 (381 bytes ) - added by raziel- 10 years ago.
blow up the doll and open the window
nippon.008 (364 bytes ) - added by raziel- 10 years ago.
kissing dough glitch

Download all attachments as: .zip

Change History (8)

comment:1 by jvprat, 10 years ago

Owner: set to peres

by raziel-, 10 years ago

Attachment: nippon.006 added

blow up the doll and open the window

by raziel-, 10 years ago

Attachment: nippon.008 added

kissing dough glitch

comment:2 by digitall, 8 years ago

Both issues replicated from the attached savegames with the latest Git master:
ScummVM 1.4.0git1898-g6ab4a0c (Aug 31 2011 21:57:38)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora AAC

Will need to check that these can be replicated from a clean game start.

comment:3 by bluegr, 8 years ago

The second issue seems to be a result of the first one, i.e. Donna is supposed to have her normal look in the scene where she kisses Doug. The kissing animation is separate from the normal one, so it was created to be used with Donna's normal look. The bug manifests in the first location, after Donna escapes with the doll, and never actually loses her disguise

comment:4 by bluegr, 8 years ago

Fixed in commit 57177e9, a regression of commit 18b48c7

comment:5 by bluegr, 8 years ago

Owner: changed from peres to bluegr
Resolution: fixed
Status: newclosed

comment:6 by bluegr, 8 years ago

A note: the script that changes Donna to her normal self is triggered right after she escapes the residence. So the second saved game is already corrupted. Both scenes play correctly after the fix using the first savegame (inside the residence)

Note: See TracTickets for help on using tickets.