Opened 13 years ago

Closed 6 months ago

#4815 closed defect (fixed)

PARALLACTION: Nippon - Explanation verbs stuck

Reported by: raziel- Owned by: digitall
Priority: normal Component: Engine: Parallaction
Version: Keywords:
Cc: Game: Nippon Safes

Description

ScummVM 1.2.0svn48243 (Mar 12 2010 07:44:55) Features compiled in: Vorbis FLAC MP3 RGB zLib

Path: Donna

Some of the explanation verbs that appear beneath the cursor when hovering over objects, keep stuck on dialog scenes and only get erased when the dialog is over 1) Eternal Rest Hotel: "telephone" keeps stuck until the door-keeper is gone 2) Sumo Wrestler "suite": "knock" will be stuck until the cutscene is played 3) Emperors mansion" Talking to the emperor in duisguise has "cabinet" floating beneath the cursor until the dialogue is finished

I'm gathering this in one report as i'm pretty sure they are all related

Nippon Safes Inc. (Multi-lingual/Amiga)

Amiga OS4 gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #2969911. Ticket imported from: bugs/4815.

Attachments (4)

nippon.021 (274 bytes ) - added by raziel- 13 years ago.
phone to the hotel and keep the pointer over "telephone"
nippon.001 (284 bytes ) - added by raziel- 6 months ago.
nippon.002 (277 bytes ) - added by raziel- 6 months ago.
nippon.007 (376 bytes ) - added by raziel- 6 months ago.

Download all attachments as: .zip

Change History (15)

comment:1 by raziel-, 13 years ago

It only happens if at the beggining of the conversation the cursor is over an explaining object (like hall, safe, bench, square etc.) but then everytime.

comment:2 by jvprat, 13 years ago

Owner: set to peres

comment:3 by Kirben, 13 years ago

Does this problem still occur? it looks like the fix for bug #2979193 prevents verbs been displayed during dialogs now.

comment:4 by raziel-, 13 years ago

Problem still there, most notable in the eternal rest lounge i'll attach a savegame

by raziel-, 13 years ago

Attachment: nippon.021 added

phone to the hotel and keep the pointer over "telephone"

comment:5 by digitall, 11 years ago

Tested attached savegame with Nippon Safes (Amiga) and: ScummVM 1.4.0git1802-g0382e99-dirty (Aug 25 2011 01:50:57) Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora AAC

This does still occur..

comment:6 by digitall, 11 years ago

To be clear of the sequence to replicate: 1. Load Savegame 2. Enter "Eternal Rest Hotel" on middle left of screen 3. Talk to Doorkeeper, Ask about Leaving a Message. 4. Examine Pigeonholes to see where Message is. 5. Use Pen on Phone (To Call Door-Keeper). The phone conversation will start. Since the cursor is still over the phone, Telephone is displayed.. but this is not removed when the conversation starts and persists attached to the cursor...

comment:7 by raziel-, 2 years ago

Summary: NIPPON: Explanation verbs stuckPARALLACTION: Nippon - Explanation verbs stuck

comment:8 by digitall, 6 months ago

https://github.com/scummvm/scummvm/pull/3820 which was merged as commit https://github.com/scummvm/scummvm/commit/547d4be632becb56d33a876b5b638943cd1a8da3 has fixed the issue at the Eternal Rest Hotel.

Will need to test to confirm if the other two cases do still occur with this fix...

comment:9 by raziel-, 6 months ago

1), 2) and 3) confirmed fixed

1) save nippon.001 - Use the pen with one of the phones and keep the cursor over the phone (fixed)
2) save nippon.002 - "Open" the door ("knock") and keep the mouse pointer over the "knock" - fixed
3) save nippon.007 - "Open" the door (be quick to move the cursor over the middle closed cabinet)

Last edited 6 months ago by raziel- (previous) (diff)

by raziel-, 6 months ago

Attachment: nippon.001 added

by raziel-, 6 months ago

Attachment: nippon.002 added

by raziel-, 6 months ago

Attachment: nippon.007 added

comment:10 by digitall, 6 months ago

Since these bugs have been confirmed by raziel- as fixed, closing as fixed.

comment:11 by digitall, 6 months ago

Keywords: script removed
Owner: changed from peres to digitall
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.