Opened 10 years ago

Closed 9 years ago

#4809 closed defect (fixed)

NIPPON: Wrong inventory item labels

Reported by: raziel- Owned by: peres
Priority: normal Component: Engine: Parallaction
Keywords: script Cc:
Game: Nippon Safes

Description

ScummVM 1.2.0svn48243 (Mar 12 2010 07:44:55)
Features compiled in: Vorbis FLAC MP3 RGB zLib

Path: Dough

In Hot Sushi the verbs shown for all kind of persons are wrong
1) Max is shown as "Max & Kos" whereas Kos is shown as "Kos"
2) The weird guy in the corner is shown as "sweird guy" in the top half and "weird guy" in the bottom half of the sprite
3) When Dough tries to read the letter it's shown as "exit" on him and not as "read letter" or similar

I'm gathering this in one report as i'm pretty sure they are all related

Nippon Safes Inc. (Multi-lingual/Amiga)

Amiga OS4
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #2969242. Ticket imported from: bugs/4809.

Change History (9)

comment:1 by jvprat, 10 years ago

Owner: set to peres

comment:2 by raziel-, 10 years ago

Path: Donna

1) Prison Guard is shown as "Secondo"
2) In the suite of the sumo wrestler "knock" is displayed instead of dorr when hovering over it
3) When Donna gets the autograph of Suzi Yong it is displayed as "window" instead of "look at autograph"
4) At the news paper stand it is displayed as "buy the ticket" when it has to be "look at the poster"

comment:3 by peres, 10 years ago

Dough:

2) it's a script bug

Donna:

1) the name of the prison guard is "Secondo", a lame wordplay of the Italian "secondino" for prison guard

comment:4 by wjp, 10 years ago

The wrong inventory item strings are likely caused by the same issue as #2969257

comment:5 by Kirben, 10 years ago

1) Occurs in the original Amiga version, so not a bug.

comment:6 by Kirben, 10 years ago

Path Dough: Issues 1 and 2 both occur in the original Amiga version too.

Updated the summary, since only the inventory item labels are a bug specific to ScummVM.

Bug #2880944 was duplicate, and states the issues with flyers and letters, occur in all locations.

comment:7 by Kirben, 10 years ago

Summary: NIPPON: Verbs Wrong in Hot Sushi (possbily more)NIPPON: Wrong inventory item labels

comment:8 by Kirben, 9 years ago

Resolution: fixed
Status: newclosed

comment:9 by Kirben, 9 years ago

The incorrect inventory item labels no longer occur, and must have been fixed by the recent changes to labels code.

Note: See TracTickets for help on using tickets.