Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4808 closed defect (fixed)

NIPPON: Save/Load dialog empty

Reported by: raziel- Owned by: peres
Priority: blocker Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

ScummVM 1.2.0svn48243 (Mar 12 2010 07:44:55)
Features compiled in: Vorbis FLAC MP3 RGB zLib

The save load dialog (accessable via "S" and "L") is completely empty.
Saving games work as they are created, but loading is impossible due to NO game file is shown in the dialog.

Nippon Safes Inc. (Multi-lingual/Amiga)

Amiga OS4
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #2969234. Ticket imported from: bugs/4808.

Change History (8)

comment:1 Changed 9 years ago by jvprat

Owner: set to peres

comment:2 Changed 9 years ago by Kirben

The problem is saving games uses the gameid (ie nippon), while listing saved games uses the game target (ie nippon-amiga).

comment:3 Changed 9 years ago by Kirben

Priority: normalblocker

comment:4 Changed 9 years ago by fingolfin

Peres commited a patch for this to branch and trunk, and LordHoto later revised it on trunk to be less hackish.

Could you please check whether this resolves the issue for you? Ideally using both branch and trunk. Thanks!

comment:5 Changed 9 years ago by raziel-

Sorry, unfortunately not

I still have a blank dialog, even right after saving a game

Worst is that now after the patch renaming the once saved nippon.00x games to nippon-amiga.00x doesn't help anymore, the whole dialog stays blank

comment:6 Changed 9 years ago by raziel-

r48422 fixed the problem

thank you

comment:7 Changed 9 years ago by Kirben

Status: newclosed

comment:8 Changed 9 years ago by Kirben

Resolution: fixed
Note: See TracTickets for help on using tickets.