Opened 9 years ago

Closed 9 years ago

#4806 closed defect (fixed)

NIPPON: Crash in Intro

Reported by: raziel- Owned by: lordhoto
Priority: high Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

ScummVM 1.2.0svn48243 (Mar 12 2010 07:44:55)
Features compiled in: Vorbis FLAC MP3 RGB zLib

The Intro scene where Dino breaks loose the door from the sportscar feature a recurring siren sound which unfortuinately breaks after the first sound piece and crash.

Nippon Safes Inc. (Multi-lingual/Amiga)

Amiga OS4
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #2969211. Ticket imported from: bugs/4806.

Attachments (1)

Crashlog_SDL thread 0x6757f2d0_2010-03-12_09-04-32.txt (139.8 KB) - added by raziel- 9 years ago.
Crash log

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by raziel-

Crash log

comment:1 Changed 9 years ago by jvprat

Owner: set to peres

comment:2 Changed 9 years ago by Kirben

This is a regression, and doesn't occur in ScummVM 1.0.0.

comment:3 Changed 9 years ago by Kirben

Priority: normalhigh

comment:4 Changed 9 years ago by Kirben

This regression was specifically caused by revision 48018.

comment:5 Changed 9 years ago by Kirben

Owner: changed from peres to lordhoto

comment:6 Changed 9 years ago by lordhoto

I'm afraid that I can't help fixing this bug unless I have additional information.

Is that crash caused by an assert? If not could you try running gdb and supply a backtrace?

comment:7 Changed 9 years ago by Kirben

This is the second scene in the Amiga demo, so could use the demo for further information and testing.

comment:8 Changed 9 years ago by lordhoto

Resolution: fixed
Status: newclosed

comment:9 Changed 9 years ago by lordhoto

Fixed with r48356 in trunk. Backported to branch-1-1-0 with r48357.

Note: See TracTickets for help on using tickets.