Opened 10 years ago

Closed 9 years ago

#4799 closed defect (fixed)

Zak/FM-Towns: Crash after epilogue

Reported by: SF/inguin Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

ScummVM dies with a failed assertion just after the epilogue of Zak McKracken (FM-Towns version):

scummvm: engines/scumm/sound.cpp:106: virtual void Scumm::Sound::addSoundToQueue2(int, int, int, int): Assertion `_soundQue2Pos < ((int)(sizeof(_soundQue2) / sizeof(_soundQue2[0])))' failed.
Aborted (core dumped)

ScummVM 1.1.0svn48158
Fedora 12, x86-32
reproducible with attached savegame

Ticket imported from: #2964507. Ticket imported from: bugs/4799.

Attachments (1)

zak-fm.s06 (20.8 KB ) - added by SF/inguin 10 years ago.
Savegame immediately before the epilogue

Download all attachments as: .zip

Change History (5)

by SF/inguin, 10 years ago

Attachment: zak-fm.s06 added

Savegame immediately before the epilogue

comment:1 by Kirben, 10 years ago

I'm unable to reproduce the assertion, with the attached saved game, when
using ScummVM SVN under Windows XP.

comment:2 by SF/inguin, 10 years ago

I can no longer reproduce this with 1.2.0svn48557. Either this has been fixed within the last month or it's indeterminate. Feel free to close this bug.

comment:3 by sev-, 9 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:4 by sev-, 9 years ago

OK, closing.

Note: See TracTickets for help on using tickets.