Opened 9 years ago

Closed 9 years ago

#4796 closed defect (fixed)

FOTAQ: Floda Alarm Tone Won't Stop

Reported by: SF/maplesyrup Owned by: eriktorbjorn
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

In Flight of the Amazon Queen when you left the building after the Floda alarm went off, a single tone from the alarm would constantly play afterward. The tone only went away by restarting the engine.

game version: Talkie/DOS/English
Windows 7 64-bit
1.1.0 svn 48157

Ticket imported from: #2961891. Ticket imported from: bugs/4796.

Attachments (1)

fotaq-music.diff (335 bytes) - added by eriktorbjorn 9 years ago.
Patch against current SVN

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by eriktorbjorn

If it's where I think it is (after rescuing the princess), I couldn't reproduce it when I tried. In fact, I didn't hear any sound effect from the alarm at all.

On the other hand, in an earlier scene when the music changed, a note from the old song seemed to be playing over the new one. Were you able to tell if the tone you heard was a sound effect or a musical note? It looks to me like it doesn't explicitly stop the old music when the new one starts.

comment:2 Changed 9 years ago by SF/maplesyrup

Yes, I believe it's a musical note. You're right, there was no alarm sound just music.

comment:3 Changed 9 years ago by fingolfin

So this sounds like a hanging MIDI note bug.

Changed 9 years ago by eriktorbjorn

Attachment: fotaq-music.diff added

Patch against current SVN

comment:4 Changed 9 years ago by eriktorbjorn

Hmm... I could have sworn I wrote a comment when I attached the patch. Anyway, what I wanted to say is that it could very well be as simple as just stopping the current song before playing the next one. I don't know why we don't do that already, and I played through the beginning of the game - up to the plane crash - with the patch, without noticing any problems with it.

comment:5 Changed 9 years ago by joostp

Explicitly stopping the music seems a safe change to me.

I've just tested the patch too in a few areas where it might have been problematic (where music is queued), but I've not noticed any problems.

comment:6 Changed 9 years ago by eriktorbjorn

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:7 Changed 9 years ago by eriktorbjorn

Ok, I've committed the patch to the trunk. It's probably a bit too late to get it into the branch. It doesn't strike me as a serious bug.

Note: See TracTickets for help on using tickets.