Opened 10 years ago

Closed 10 years ago

#4782 closed defect (invalid)

DW - Lost Firecrackers

Reported by: SF/huzelbub Owned by: dreammaster
Priority: normal Component: Engine: Tinsel
Keywords: script Cc:
Game: Discworld

Description

On the quest for the items that make a hero I got the firecrackers and powder out of the chest at the city gate. Then I got Mambo the dragon and immediately fed the crackers to him. He went to "M16" in the inventory. Now in order to get the parrot for the sailor I have to throw a firecracker at him, but the crackers seem to have vanished after I fed them to Mambo. Searching the chest at the gate again Rincewind says he already got these.

This happened with the English SCN version on ScummVM 1.0.0 (I didn't test the nightly build because I don't have a save game prior to the bug or the time to replay the whole game) on WinXP x64.

Ticket imported from: #2959795. Ticket imported from: bugs/4782.

Attachments (1)

dw.004 (4.3 KB ) - added by SF/huzelbub 10 years ago.
Save Game with the crackers gone

Download all attachments as: .zip

Change History (6)

by SF/huzelbub, 10 years ago

Attachment: dw.004 added

Save Game with the crackers gone

comment:1 by dreammaster, 10 years ago

Okay, the problem is that there's no way you're meant to be able to get Mambo in Act III. He's inside the dragon enclosure, and you're only able to get the key from Lady Ramkin when she's been chained to the rock at the start of Act IV.

I did a quick experimentation with jumping to Act III and going to the enclosure scene, and I couldn't get Mambo from outside the enclosure. So maybe if you could expand on how you managed to get him, the problem can be looked into further.

comment:2 by SF/huzelbub, 10 years ago

Ah, now that explains a lot. I got Mambo at the same time while getting the leash and the thing with the ribbon after luring the Lady to the front door. I did some clicking around the cage and somehow got inside where I was able to pick him up. I guess the locked door to the cage is somewhat penetrable.

I did a quick search but couldn't find a way to jump to a specific part of the game. Could you please give me (a link to) instructions on how to jump to Act III so I can look into how I've done it (can't exactly remember) - and finish the game without replaying it all?

comment:3 by dreammaster, 10 years ago

If you use Ctrl-D to open the debugger console when running the game, you can use the 'scene' command to jump to a particular scene. The page at
http://wiki.scummvm.org/index.php/Tinsel/List_of_Scenes has a list of the available scenes for both versions of the game.

In this case, for example, you should first jump to the the 'Act III' cutscene, and then enter the scene for the dragon enclosure.

comment:4 by SF/huzelbub, 10 years ago

Sorry I found no way to reproduce this. I have absolutely no idea how I managed to get inside the enclosure in Act III. You may close this report as I doubt somebody will accidently run into this again.

But thanks to your hint I was able to create a new set of crackers with the debug console and finish the game.

comment:5 by dreammaster, 10 years ago

Owner: set to dreammaster
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.