Opened 17 years ago

Closed 17 years ago

Last modified 11 months ago

#477 closed defect (worksforme)

Crash when wrong path used in config file

Reported by: SF/dfabulich Owned by: SF/ender
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

OK, so I may have made a slight typo in my scummVM
setup, but that doesn't mean I deserve to have the
whole thing crash on me! I was trying to test out Sam
and Max; I thought the whole build was broken.

This should be an easy fix; just a little better error
handling is all we need here.

ScummVM 0.2.2 CVS
Built on Sep 29 2002 21:23:48

Ticket imported from: #616286. Ticket imported from: bugs/477.

Change History (9)

comment:1 by fingolfin, 17 years ago

OK, so..
* why is this attributed to NewGUI?
* what is actually the problem you encounter?
* how can we reproduce it?

comment:2 by SF/dfabulich, 17 years ago

> * why is this attributed to NewGUI?

It looked like that was the problem as I encountered it. It
was the only change I noticed as I was using ScummVM, but I
could be wrong.

> * what is actually the problem you encounter?

On Win2K pro, ScummVM halts, and the mouse is inaccessible.
I can't (easily) terminate the program. All I can do is
press the Windows key to bring up the Start Menu; then I hit
escape and Alt-Space to bring up the window menu for the
task bar. I type "M" to move the bar and press up to bring
the taskbar onto the screen. Then, finally, I press tab and
use the arrow keys to navigate to the ScummVM game window,
hit the menu key and use the arrow to select "Close."

> * how can we reproduce it?

Take today's build and specify an incorrect path in
scummvm.ini. Start up ScummVM and try playing Sam N Max.
The game should then crash.

comment:3 by fingolfin, 17 years ago

Summary: NewGUI: crashes when .ini path is wrongCrash when wrong path used in config file

comment:4 by SF/ender, 17 years ago

Can you define 'a wrongpath' a little clearer?
Do you mean a path that is invalid (Eg, illegal) or a path that just doesn't
contain the required files?

Also, this type of problem is quite often dependent on operating systems,
as they all use a slightly different method of referencing path information...
because you talk about scummvm.ini, I'm going to assume your using some
Windows version. Could you give me a little more info? :)

Thanks.

comment:5 by SF/dfabulich, 17 years ago

In my case, the path pointed to a non-existent directory,
but I just went back and reproduced it in a directory that
doesn't contain the proper files; same problem. In both
cases the path was well-formed.

As I said in an earlier comment, I'm using Windows 2000
Professional. Is there anything else I can tell you that
would help?

comment:6 by SF/ender, 17 years ago

Oops, sorry.. didn't see the "Win2k Pro" bit :)

Well, I'm lost. It's either a problem with that specific build, or Windows...
because I can't replicate it with the latest CVS, either using -p or a config
file:

ender@greatwhite:~/code/scummvm$ ./scummvm -p
/something/doesnt/exist/ samnmax
Detected game 'Sam & Max', version 6.4.2
Error(0:0:0x0): ask Cannot find 'samnmax.000'!
ender@greatwhite:~/code/scummvm$

I'll see if I can find someone to compile the latest code on Windows and test
- it's possible there was something slightly barfed in the build for the 29th
that simply isn't there now.

comment:7 by SF/ender, 17 years ago

Owner: set to SF/ender
Resolution: worksforme
Status: newclosed

comment:8 by SF/ender, 17 years ago

This just wasn't repeatable over here. Closing.

comment:9 by digitall, 11 months ago

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.