Opened 10 years ago

Closed 10 years ago

#4722 closed defect (fixed)

FOA: Won't launch in Win32

Reported by: SF/scorches-forge Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Indiana Jones and the Fate of Atlantis
FM-Towns, Japanese
ScummVM 1.1.0svn46243, Win32

When I attempt to launch the game, this is the message I receive.

Console is ready
Debugger started, type 'exit' to return to the game.
Type 'help' to see a little list of commands and variables.
ERROR: (0:1:0x4E4): SO_LOAD_STRING: Unsupported filename *h*p*w** !

The filename is a garbage 8 charcters long followed by a '!'. Example = *h*p*w** !

Except the asteriks (*) represent chars not on my keyboard.

Going back and double-checking, the last version where my game at least loaded was ScummVM version '0.13.1', even though then it had minor graphic anomolies.

Ticket imported from: #2908376. Ticket imported from: bugs/4722.

Change History (4)

comment:1 by fingolfin, 10 years ago

Thanks for the report.

OK, it's pretty clear what the cause for this is, it's the way we implement SO_LOAD_STRING: we look for a filename that starts or ends with "iq" -- this fails in the japanese version of the game

Proposed fix: Let's modify SO_SAVE_STRING & SO_LOAD_STRING to only work in Indy3/Indy4; also, *always* use the .iq file name. No other game uses these opcodes, as far as I know anyway.

comment:2 by fingolfin, 10 years ago

Summary: INDY4: Wont Launch in Win32FOA: Wont Launch in Win32

comment:3 by fingolfin, 10 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Summary: FOA: Wont Launch in Win32FOA: Won't launch in Win32

comment:4 by fingolfin, 10 years ago

This should be fixed in SVN. You could try it with the next daily build.

Note: See TracTickets for help on using tickets.