Opened 11 years ago

Closed 11 years ago

#4721 closed defect (worksforme)

DOTT: missing sounds with 1.0.0 and latest SVN

Reported by: SF/phanboy_iv Owned by:
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Day of the Tentacle

Description

Version: 1.0.0 and latest (as of 12/3/2009) SVN build Game Language: English Game Version:CD-ROM Platform: Win32 Details: Recently decided to fire DOTT (UK CD-ROM release) back up again, and noticed that with 1.0.0, during the intro cutscene the tentacles' "schlepping" noise is missing, along with console error messages saying "Failed to load sound!" "End of File while reading from Vorbis file!" I'm using a Vorbis compressed monster.sou encoded with default options. Rolling back to 0.13.1 showed that it did not have this problem, as the sounds were there and no errors occurred. Tried re-copying the file and re-encoding it, same result. I assume that the UK release has the exact same .sou file as the US, but regardless this is a new bug with the new version. Screen of error message attached.

Ticket imported from: #2908259. Ticket imported from: bugs/4721.

Attachments (1)

scumm100DOTTSoundError.jpg (71.7 KB ) - added by SF/phanboy_iv 11 years ago.
Screenshot of console error

Download all attachments as: .zip

Change History (8)

by SF/phanboy_iv, 11 years ago

Attachment: scumm100DOTTSoundError.jpg added

Screenshot of console error

comment:1 by eriktorbjorn, 11 years ago

I can't reproduce that on my Linux box, though I compressed that file years ago. If the error is in the compression tool, rather than in ScummVM itself, that could invalidate the test. I just moved to a new apartment, so my original CD is still stored away in some box somewhere.

One rather far-fetched idea would be that there's a second, damaged tentacle.sog or monster.sog somewhere that ScummVM 1.0.0 finds and uses, but 0.13.1 doesn't. But I don't know if the file handling has changed enough between those two versions for that to be even possible.

comment:2 by SF/phanboy_iv, 11 years ago

I re-compressed the file with the latest scummvm-tools, and still get the errors with 1.0.0 and not with 0.13.1

I don't think it's finding the wrong file as the .sou files are always looked for in the game directory, and always have been as far back as I recall.

I'll try it on my Linux box, it may be a Windows-specific issue, or even a Windows 7 specific issue, though I doubt that.

comment:3 by fingolfin, 11 years ago

Are other sounds playing fine, or are no sounds playing?

Does this error occur with an uncompressed monster.sou ? Or with an compressed one? Or both?

Thanks!

comment:4 by fingolfin, 11 years ago

Summary: DOTT missing sounds with 1.0.0 and latest SVNDOTT: missing sounds with 1.0.0 and latest SVN

comment:5 by SF/wickedshell, 11 years ago

I can't reproduce this error with 1.0.0, 1.1.0 or with the latest svn build. I'm using an uncompressed monster.sou, from the english CD. I compressed monster.sou to a vorbis, and I still can't recreate this (1.1.0 and svn).

He stated that he's using a vorbis compressed file. But he didn't say if it worked with an uncompressed monster.sou

comment:6 by SF/phanboy_iv, 11 years ago

Resolution: worksforme
Status: newclosed

comment:7 by SF/phanboy_iv, 11 years ago

Just tested with latest stable version, the issue no longer occurs. Closing.

Note: See TracTickets for help on using tickets.