Opened 10 years ago

Closed 10 years ago

Last modified 15 months ago

#4695 closed defect (fixed)

ScummVM segfaults when executed

Reported by: hkzlab Owned by: fingolfin
Priority: normal Component: Port: Linux
Keywords: Cc:
Game:

Description

Tested on trunk revision 45619, ScummVM compiled with default engines and dynamic plugins. ScummVM segfaults immediately when executed on linux. Amd64 arch, Ubuntu 9.10 . I have attached the valgrind output.

Ticket imported from: #2890990. Ticket imported from: bugs/4695.

Attachments (1)

valgrind.txt (2.1 KB ) - added by hkzlab 10 years ago.
Valgrind output when executing ScummVM

Download all attachments as: .zip

Change History (5)

by hkzlab, 10 years ago

Attachment: valgrind.txt added

Valgrind output when executing ScummVM

comment:1 by eriktorbjorn, 10 years ago

Does it only happen when using dynamic plugins?

comment:2 by hkzlab, 10 years ago

i've tested with dynamic plugins only. Though the problem doesn't happen anymore, fingolfin committed a fix in r45620. "TINSEL: Fix regression caused by the introduction of _vm->_config; proper fix will be introduced later, when dialogs.cpp gets objectified"

I guess the report can be closed.

comment:3 by hkzlab, 10 years ago

Resolution: fixed
Status: newclosed

comment:4 by digitall, 15 months ago

Component: Port: Linux
Note: See TracTickets for help on using tickets.