Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#4672 closed defect (fixed)

Pajama Sam's Lost & Found - Glitches when picking up item

Reported by: Strangerke Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Pajama Sam's Lost and Found

Description

Here are some graphic gitches I noticed while playing the game. Note that they are only the first occurrence of the problem, if they occur in other levels I just ignored them.
X8Y4M, level 12. Water animation appears when taking the flying saucer. The screen is so screwed it's hard to finish the level
2J9U7, level 15 "of 100" appears when taking the telescope.
Y1S1B, level 16. inventory screwed when taking Godzilla
4P7R8, level 24. Inventory diseappeard, plus blinking glitch when taking little pig
X8N5F, level 33. Animated wheel appears when taking the baseball card
M3D6L, level 44. Weird blue thing appearing in the bottom left of the screen when taking the shoe.
7Z4H6, level 49. inventory differently screwed when taking the magazine
A2N8D, level 58. Weird things appearing in the middle of the screen after taking the sock.
8V9R8, level 59. Inventory screwed another way by taking the baseball glove
5DJW9, level 68: seaweed (not sure...) appearing when taking the scisors
B6R4Y, level 71. inventory screwed when taking the globe, and screwed screen when taking the socks
DM9L4, level 72. inventory screwed a new blinking way when taking the pencil, and bottom-right of the screen is screwed a new way when taking the baseball glove
122K5, level 78. "ems of 100" appears when taking the telescope

I've added some screenshots, in case it helps.

Ticket imported from: #2880968. Ticket imported from: bugs/4672.

Attachments (7)

2J9U7.png (20.7 KB ) - added by Strangerke 10 years ago.
screenshot
4P7R8.png (23.6 KB ) - added by Strangerke 10 years ago.
screenshot
122K5.png (13.2 KB ) - added by Strangerke 10 years ago.
screenshot
A2N8D.png (21.2 KB ) - added by Strangerke 10 years ago.
screenshot
X8N5F.png (22.8 KB ) - added by Strangerke 10 years ago.
screenshot
X8Y4M.png (18.2 KB ) - added by Strangerke 10 years ago.
screenshot
Y1S1B.png (23.7 KB ) - added by Strangerke 10 years ago.
screenshot

Download all attachments as: .zip

Change History (12)

by Strangerke, 10 years ago

Attachment: 2J9U7.png added

screenshot

by Strangerke, 10 years ago

Attachment: 4P7R8.png added

screenshot

by Strangerke, 10 years ago

Attachment: 122K5.png added

screenshot

by Strangerke, 10 years ago

Attachment: A2N8D.png added

screenshot

by Strangerke, 10 years ago

Attachment: X8N5F.png added

screenshot

by Strangerke, 10 years ago

Attachment: X8Y4M.png added

screenshot

by Strangerke, 10 years ago

Attachment: Y1S1B.png added

screenshot

comment:1 by Strangerke, 10 years ago

I forgot to mention : it's the US english version of the game

comment:2 by Kirben, 9 years ago

This bug is specific to the HE98 version, and is listed on the HE TODO.

comment:3 by Kirben, 9 years ago

Status: newclosed

comment:4 by Kirben, 7 years ago

Resolution: fixed

comment:5 by Kirben, 7 years ago

All the glitches have been fixed in ScummVM GiT, and were caused by room 6 script 255 never been resumed in the HE98 version of the game.

Note: See TracTickets for help on using tickets.