Opened 10 years ago

Closed 9 years ago

Last modified 9 months ago

#4667 closed defect (invalid)

CAULDRON: Gfx Priority issue

Reported by: raziel- Owned by: sev-
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Black Cauldron

Description

ScummVM 1.1.0svn45110 (Oct 15 2009 13:03:50)
Features compiled in: Vorbis FLAC MP3 RGB zLib

While performing the "Flying Dust" stunt *g* and standing with ego behind a tree (or any other "foreground" object) makes ego appear BEFORE that object (making it look like, ego pops out of a tree in this case). Seems to be the handling of the "special animation" for the flying spell(?)

Screenshot attached, save game will follow

The Black Cauldron (2.00 1987-06-14/Amiga/English)

AmigaOS4
gcc version 4.2.4 (adtools build 20090118)

On a side note, there doesn't seem to be an entry for "The Black Cauldron" in the "Group" menue...

Ticket imported from: #2879872. Ticket imported from: bugs/4667.

Attachments (2)

SGrab_Shot_000.png (45.1 KB) - added by raziel- 10 years ago.
ego preparing the flying spell (popping out of a tree)
bc-amiga.001 (4.9 KB) - added by raziel- 10 years ago.
ego standing already behind tree, just perform the flying

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by raziel-

Attachment: SGrab_Shot_000.png added

ego preparing the flying spell (popping out of a tree)

Changed 10 years ago by raziel-

Attachment: bc-amiga.001 added

ego standing already behind tree, just perform the flying

comment:1 Changed 9 years ago by sev-

Not a bug. This is how it is supposed to be. Ego gets maximum prioroty and thus it gets drawn always. Checked with NAGI and original interpreter.

comment:2 Changed 9 years ago by sev-

Owner: set to sev-
Resolution: invalid
Status: newclosed

comment:3 Changed 9 months ago by digitall

Component: Engine: AGI
Game: Black Cauldron
Note: See TracTickets for help on using tickets.