Opened 10 years ago

Closed 10 years ago

#4657 closed defect (duplicate)

BASS: crash switching screen mode during intro cutscene

Reported by: (none) Owned by: sev-
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

Using ScummVM 1.0.0rc143760 (Aug 26 2009 22:15:01) with its default settings, on Mac OS 10.6, on a MacBookPro3,1 (Core2Duo - fall 2007).

Beneath a Steel Sky 0.0372 CD Talkie in English (this is the version available on ScummVM's download page), crashes when switching screen mode to and from Fullscreen mode while the first character of the introduction cutsene starts talking.
It is possible to avoid the crash by waiting for the next image to switch screen modes, or by skipping the intro cutsene.

1. Start the game with default ScummVM settings, it should then launch it in Windowed Mode.
2. After the logos, wait for the narrator finishes to speak.
3. When the first character starts talking "Ohh I see evil from deep beneath the city..." and the image of his eyes appears, press Alt Enter to switch to fullscreen (or to windowed mode, if you were in fullscreen previously).
4. ScummVM crashes and Mac OS X returns to the Finder with a detailed bug report to send to Apple.

The behaviour seems similar to bug #1849081, but here you have to swtich screen modes in order to trigger the crash, otherwise it works well. Doing it while the narrator speaks (when the screen is still black) doesn't trigger it, neither during the following images of the cutscene.

Ticket imported from: #2878133. Ticket imported from: bugs/4657.

Attachments (1)

BASS-intro-crash-AppleBugrRport.txt (30.3 KB ) - added by SF/*anonymous 10 years ago.
Bug reported generated by Mac OS X

Download all attachments as: .zip

Change History (7)

by SF/*anonymous, 10 years ago

Bug reported generated by Mac OS X

comment:1 by (none), 10 years ago

Summary: crash when switching fullscreen/widow during intro cutsceneBASS: crash switching screen mode during intro cutscene

comment:2 by (none), 10 years ago

Oops... would this be a duplicate of 1690813 ?

comment:3 by eriktorbjorn, 10 years ago

I can reproduce this on my Llinux box. I have a hunch that it's related to the processSequence() function. It appears to be called from a timer handler, i.e. from a different thread, and that sort of thing has caused us trouble in the past. (The Full Throttle action sequences spring to mind.)

comment:4 by eriktorbjorn, 10 years ago

> Oops... would this be a duplicate of 1690813 ?

I didn't read that until after I mad posted my earlier comment. I would guess that it's the same kind of bug, at the very least.

comment:5 by sev-, 10 years ago

Owner: set to sev-
Resolution: duplicate
Status: newclosed

comment:6 by sev-, 10 years ago

Closing as a duplicate of #1690813

Note: See TracTickets for help on using tickets.