Opened 10 years ago

Closed 9 years ago

Last modified 13 months ago

#4629 closed defect (worksforme)

WII: sword1 & dig crashes when ogg compression used

Reported by: SF/kmlst Owned by: dhewg
Priority: normal Component: Port: Wii
Keywords: Cc:
Game:

Description

error quoted:
-begin-
assertion "!err" failed: file "../../src-trunk/src/sound/vorbis.cpp" line 147. function: Audio::VorbisInputStream::VorbisInputStream(SeekableReasStream*, bool, uint, uint, uint)
Abort called.
ScummVM exited abnormally (-127).
-end-
Platform : wii
Version:c1.0.0rc1 and wii-trunk-r44198
Compression: vorbis
Game & error
1) Dig, The (dig-de) [german]
crashing emediately after game start, even no intro shown
2) Broken Sword 1 (sword1) [german]
error same as above, but latest point happening is after newspaper is given to the streetworker who leaves to place a horse race bet. He stands up and asks to look after his stuff while he places the bet, and the game crashes before he makes the 1st step of walking away.
sometimes the crash happens earlier (1st talking to nico) but at the bet always.

the same datafiles work fine on PC (Linux) (no errors shown on console while playing)
tried recompression 2 times, tried 3 different (brands) of SD cards on 2 wiis and fsck'd all cards.
savegame (sword1) will follow.

Ticket imported from: #2869337. Ticket imported from: bugs/4629.

Change History (21)

comment:1 by dhewg, 10 years ago

I replaced that assert recently, so instead of just exiting you should get a few more details why it failed. Please try a fresh trunk nightly build. Open the console with dpad up+1, then try again. You should get a vorbis related error message with an error code, please post that here.

comment:2 by dhewg, 10 years ago

Owner: set to dhewg

comment:3 by lordhoto, 10 years ago

Summary: wii port sword1 & dig-de crashes when ogg compression usedWII: sword1 & dig crashes when ogg compression used

comment:4 by SF/kmlst, 10 years ago

redone the tests with wii-trunk-r44455
btw, i got the console with dpad left+1 :)
sword1 behaved differently: it still crashes but, earlier in the newspaper dialogue.
last console output is 3 times a

-begin-
WARNING: Could not create Vorbis stream (-128)!
-end-

the dig still crashes directly at the beginning.
the output is:

-begin-
WARNING: Could not create Vorbis stream (-128)!
(1:2001:0x1A46):rate effect can only handle rates < 65536!
-end-

after the errors came, the wii became non responsive (wiimode disconnected also) an had to be turned off.

comment:5 by SF/kmlst, 10 years ago

partly solved since 1.0.0pre04468:
the sword1 scene in question works now,

dig-de starts, opening video sequences running, but remain silent.
the ingame sounds and speech are working

comment:6 by dhewg, 10 years ago

I noticed some changed by other devs about sound streams. I this problem still present with your dig-de copy?

comment:7 by SF/kmlst, 10 years ago

tested with latest SVN (1.2.0svn48869)
ogg-bug in dig-de still present
(no audio in all beginning cutscenes normal audio in the game)

comment:8 by dhewg, 10 years ago

-128 is OV_EREAD, which happens when seeking in or reading from the ogg file isn't successful.

Since you mentioned that fsck and reencoding didn't help, I guess its an incompability with Tremor. In contrast, the Windows/Linux port uses libogg and libvorbis.

Which version of oggenc did you use? I remember such an incompatibility which could be worked around with a recent oggenc.

comment:9 by SF/kmlst, 10 years ago

I ran ogginfo over the dig's ogg.files: altough sizes, lengths etcf course vary, some of the output is always the same:
below the ogginfo output for the 1st file in order:

Processing file "alcove.ogg"...

Note: Stream 1 has serial number 0, which is legal but may cause problems with some tools.
New logical stream (#1, serial: 00000000): type vorbis
Vorbis headers parsed for stream 1, information follows...
Version: 0
Vendor: Xiph.Org libVorbis I 20070622 (1.2.0)
Channels: 2
Rate: 22050

Nominal bitrate: 66,666000 kb/s
Upper bitrate not set
Lower bitrate not set
Vorbis stream 1:
Total data length: 40649 bytes
Playback length: 0m:05.501s
Average bitrate: 59,109734 kb/s

as i mentioned before the ingame audio works fine.

after your changes there is also no more initial crash in dig-de, but the pre-game (LA logo, dig logo, observatory, press conference) play w/o audio.

if you can tell me the files containing the cutscenes I'll redo compresson for those files only with the actual oggenc (1.4.0) so we can find out if this solves the problem

comment:10 by dhewg, 10 years ago

That would be sq1.ogg

I got the same output with ogginfo on my files, same "Note", same libVorbis etc. Its Dig-EN, but the audio plays just fine here, with 1.1.0 and trunk.

comment:11 by fingolfin, 9 years ago

Kamil, is the issue still present in latest SVN? ANd is it also present with the 1.1.1 release version? As opposed to a binary created by yourself, mean.

comment:12 by dhewg, 9 years ago

Kamil, any news on this? Could you resolve it?

comment:13 by dhewg, 9 years ago

Kamil? Ping!
Any word about this?

comment:14 by fingolfin, 9 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:15 by fingolfin, 9 years ago

Status: newpending

comment:16 by SF/kmlst, 9 years ago

Status: pendingnew

comment:17 by SF/kmlst, 9 years ago

sry for being unavailable so long
OTOH it also seems a pity that nobody apart from myself never tried german DIG on the wiiport. (or simply doesn't care) if I should literally the only one - well i suggest to set the priority to 1 and wait for a codec wonder :)

as fars the bug is concerned, yes it is still there: no ogg audio in the beginning sequences, no trouble when the game actually begins. (tried with 52679)

comment:18 by fingolfin, 9 years ago

What is the status of this item?

comment:19 by dhewg, 9 years ago

Resolution: worksforme
Status: newclosed

comment:20 by dhewg, 9 years ago

watched the dig intro at a buddy.
latest wii nightly build, dig-de, compressed with ogg. no problems, audio is there from start to end.
although his alcove.ogg file was ~11s

looks like you're the only one running into it. is your dig copy okay? mixing languages or something?
i don't see anything i could do about it. hence killing this.

comment:21 by digitall, 13 months ago

Component: Port: Wii
Note: See TracTickets for help on using tickets.