Opened 10 years ago

Closed 10 years ago

Last modified 13 months ago

#4580 closed defect (fixed)

WEB: Zak missing on md5 page

Reported by: SF/mthreepwood Owned by: SF/fredrik_w
Priority: normal Component: Web
Keywords: Cc:
Game:

Description

On the md5 sums page (http://www.scummvm.org/documentation/md5sums/), the entire Zak McKracken section does not appear. It is still in the md5 text file, of course, but it doesn't appear on the site.

A quick guess would be that the Misc FM-Towns demos are somehow "taking over" the zak tag and the website therefore skips the first zak section (the real Zak McKracken md5 table) as they share the zak tag.

Ticket imported from: #2847559. Ticket imported from: bugs/4580.

Change History (5)

comment:1 by SF/fredrik_w, 10 years ago

Well, the problem is not in the code, but in the scumm-md5.txt file.

There are two entries that uses 'zak' as the gameid, the first one (line 93) is the one for the game. The second one (line 241) is for "Misc FM-TOWNS demos". Changing the second one to use "misc" or "fmtowns" as the gameid will solve the issue.

comment:2 by SF/fredrik_w, 10 years ago

Well, the problem is not in the code, but in the scumm-md5.txt file.

There are two entries that uses 'zak' as the gameid, the first one (line 93) is the one for the game. The second one (line 241) is for "Misc FM-TOWNS demos". Changing the second one to use "misc" or "fmtowns" as the gameid will solve the issue.

comment:3 by SF/fredrik_w, 10 years ago

Okay, clone2727 explained to me on IRC that the games actually use "zak" as the gameid in ScummVM (which is totally crazy if you ask me).

Because of that I've changed to code for the page to not use the gameid as the key for the array.

comment:4 by SF/fredrik_w, 10 years ago

Resolution: fixed
Status: newclosed

comment:5 by digitall, 13 months ago

Component: Web
Note: See TracTickets for help on using tickets.