Opened 11 years ago

Closed 3 years ago

#4556 closed defect (fixed)

MANIAC V2: Purple Tentacle appears in lab after he leaves

Reported by: SF/maplesyrup Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

In Maniac Mansion (V2/DOS/English} with ScummVM SVN 1.0.0pre043561 (August 20, 2009 22:34:52) on Windows XP, purple tentacle shows up in the lab, stuck after Weird Ed chases him away. This happened after a cutscene with Dr. Fred and Purple Tentacle came up, after purple tentacle was already gone.

After that, he's stuck in the middle of the lab, but you can't interact with him.

Ticket imported from: #2842486. Ticket imported from: bugs/4556.

Attachments (1)

maniac-v2.s01 (8.4 KB ) - added by SF/maplesyrup 11 years ago.
Save game of purple tentacle stuck in the middle of the lab

Download all attachments as: .zip

Change History (5)

by SF/maplesyrup, 11 years ago

Attachment: maniac-v2.s01 added

Save game of purple tentacle stuck in the middle of the lab

comment:1 by fingolfin, 9 years ago

Summary: MANIAC: Purple Tentacle appears in lab after he leavesMANIAC V2: Purple Tentacle appears in lab after he leaves

comment:2 by digitall, 9 years ago

Still occurs with latest Git master and attached savegame: ScummVM 1.4.0git2591-g153e663-dirty (Oct 5 2011 20:45:39)

comment:3 by segrax, 3 years ago

This is caused by a scripting oversight which will occur if you enter the lab entry in less than 45 minutes since the first cutscene with Dr. Fred and Sandy has run.
Its simply because one of the cutscenes is time based, and puts Purple tentacle in the room, and leaves him on completion

These script numbers are for V0, however the V1/V2 scripts are usually (x + 5)

script-143 (Cutscene: Dr. Fred / Sandy #1) is triggered by USE on roomobj-1-28 (Outside - Front Door). At completion of the cutscene, it executes script-151.

script-151 (Cutscene: Purple Tentacle chases Sandy Trigger) delays for 45 minutes, before executing script-150.
script-150 (Cutscene: Purple Tentacle chases Sandy) puts Purple Tentacle, Sandy and Dr. Fred into the Lab Entry, and only removes Sandy at completion

script-94 (Cutscene: Weird Ed: Storm Dr. Freds Lab) puts Weird Ed in the Lab Entry and assumes purple is already present. At completion of this script, both Weird Ed and Purple are sent to Room0.

comment:4 by sev-, 3 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

A workaround was added by segrax

Note: See TracTickets for help on using tickets.