Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4555 closed defect (fixed)

WAXWORKS: Can't go down corridor in pyramid

Reported by: SF/maplesyrup Owned by: Kirben
Priority: high Component: Engine: AGOS
Keywords: Cc:
Game: Waxworks

Description

Using Waxworks (Floppy/DOS/English) (the version from GOG.com) on ScummVM SVN 1.0.0pre043561 (August 20, 2009 22:34:52) on Windows XP

There's a point in the pyramid where you can't walk any further down the corridor. It stops you from going despite it showing an opening in that direction.

Ticket imported from: #2842432. Ticket imported from: bugs/4555.

Attachments (1)

waxworks-pc.001 (3.6 KB ) - added by SF/maplesyrup 10 years ago.
Save game in the pyramid where you can't go futher down the corridor

Download all attachments as: .zip

Change History (13)

by SF/maplesyrup, 10 years ago

Attachment: waxworks-pc.001 added

Save game in the pyramid where you can't go futher down the corridor

comment:1 by SF/maplesyrup, 10 years ago

Component: Engine: AGOS
Game: Waxworks

comment:2 by SF/maplesyrup, 10 years ago

I wasn't sure if it was my error or not, such as was the case in the cemetery, so I played the original interpreter in DOSBox. This didn't happen there, So, I can confirm that the passage is supposed to be able to be walked through. I can also confirm that this is not a regression since I checked 0.13.1 and it also happened there.

comment:3 by SF/maplesyrup, 10 years ago

I loaded an older save game I had from the cemetery, and completed the cemetery level. I went into the pyramid level after that. I killed some guards and came across the slave boy statue. I then loaded up another save I had of the slave boy statue that had the same problem as the save game below. Low and behold, I could go through the corridor. Then I saved another save game, and tested it and the corridor worked. Then I restarted ScummVM and loaded the save game and it didn't work.

I think this might be related to the fallen guards, since the guard fell in the corridor exactly where you can't go any further, and when you load up the save game the guard's body isn't lying on the floor.

comment:4 by sev-, 10 years ago

Raising priority. This is a release-critical bug.

comment:5 by sev-, 10 years ago

Owner: set to Kirben
Priority: normalblocker

comment:6 by sev-, 10 years ago

Summary: Waxworks: Can't go down corridor in pyramidWAXWORKS: Can't go down corridor in pyramid

comment:7 by Kirben, 10 years ago

There was a regression in code for loading saved games, try the current Windows daily snapshot of ScummVM (just updated).

comment:8 by sev-, 10 years ago

Priority: blockerhigh

comment:9 by sev-, 10 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:10 by Kirben, 10 years ago

This problem should hopefully be fixed already, I'm just waiting for feedback on whether the problem still occurs with a fresh game.

The attached saved game is after the problem occurs, and it isn't clear exactly where in the pyramid that this problem occurs.

comment:11 by sev-, 9 years ago

Then let me close the bug and if the problem persists, then reopen it.

comment:12 by sev-, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.