Opened 10 years ago

Closed 9 years ago

#4545 closed defect (wontfix)

DC: Full Throttle Crash

Reported by: SF/threepoint Owned by: zeldin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

Full Throttle, DOS, Rev A.
Dreamcast build 1.0.0pre043499.
Compressed ".BUN", ".SAN", and ".SOU" with MP3.
Crashes with debugger prompt.

This happens right after returning to Maureen's with the forks from the junkyard, right when the pic of her and her uncle comes on screen.

The message that is displayed is as follows:
[code]
Debugger started, type 'exit' to return to the game.
Type 'help' to see a little list of commands and varia
ERROR: (89:2001:0x7CC2): createResource(Sound,663): Ou
[/code]

-

Ticket imported from: #2840017. Ticket imported from: bugs/4545.

Change History (9)

comment:1 by SF/threepoint, 10 years ago

--More Info--
There was no similar error with the same latest Windows daily build.
I built the disc with the plain files obviously, and used Bootdreams (latest) to create the disc image.

comment:2 by lordhoto, 10 years ago

It seems the error message you posted (which is cut off) should read:
"Out of memory while allocating (some integer here, which is the resource size)".

Thus I guess it seems there's just plainly memory missing. I don't know whether compressed resources may cause a memory overhead, which kills the game for your, or whether the DC plainly misses enough RAM to run The Dig under ScummVM. Maybe you can try with uncompressed files again and tell whether it works for you?

comment:3 by lordhoto, 10 years ago

Owner: set to zeldin

comment:4 by zeldin, 10 years ago

Yes, please try swapping in the original game CD before launching the game, and playing
from that instead. That should tell us if the problem is caused by overhead from compression.

comment:5 by SF/threepoint, 10 years ago

The reason I was originally going to submit a bug to the tracker was a crash after the demo derby, during the man on fire scene, it was the first crash I found for the game. This was with the 0.13.1 plainfiles and the required gamefiles on a single disc.

But after reading other submissions, I realized you need the latest SVN build tested, and you wouldn't accept the 0.13.1 bug submission.

I was completely out of cd-rs, so I created the boot image out of the latest plainfiles. I loaded the boot image in NullDC, and then disc swapped for the previously created single game disc I had created.

What I didn't realize was that the video plugin for the emulator would effect the game crashing.

I received two other crash errors in the Melonweed area before I realized that the chankast video plugin had somehow caused them, for they didn't happen when I switched to another:
1.) [code]ERROR: (21:10002:0xA301): creatResource(Sound,676): O[/code]
2.) [code]ERROR: (21:10002:0x7DE9): creatResource(Sound,672): O[/code]

I tried this with both the 0.13.1 single game disc, and the original game disc, and it seems it was just the video plugin that caused those specific errors.

I'd like to apologize for wasting your time, and I will not submit any more bugs to the tracker, without first verifying them on an actual Dreamcast unit.

comment:6 by zeldin, 10 years ago

Well, it's still a bit weird that a faulty video emulation would be able to produce this
particular type of error (out of memory)...

I realize that the need to burn a CD-R is a serious complication when trying nightly builds.
Hopefully we'll be able to support running from SD cards (using adapter cable or mainboard
modification) before long.

comment:7 by fingolfin, 10 years ago

What is the status of this item?

comment:8 by fingolfin, 9 years ago

Resolution: wontfix
Status: newclosed

comment:9 by fingolfin, 9 years ago

Closing this, based on the discussion that took place here.

Note: See TracTickets for help on using tickets.