Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4529 closed defect (fixed)

KYRA: GFX glitch at the bridge

Reported by: DrMcCoy Owned by: lordhoto
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 1

Description

GFX glitch at the broken bridge, English Amiga version, ScummVM r43280 on Debian GNU/Linux Sid amd64.

Ticket imported from: #2835715. Ticket imported from: bugs/4529.

Attachments (3)

kyra1a-gfxglitch1.png (23.6 KB ) - added by DrMcCoy 11 years ago.
One second after loading the save
kyra1a-gfxglitch2.png (24.0 KB ) - added by DrMcCoy 11 years ago.
After the guy said a line, he's suddenly drawn somewhere else
kyra1a.001 (11.0 KB ) - added by DrMcCoy 11 years ago.
Load and watch

Download all attachments as: .zip

Change History (8)

by DrMcCoy, 11 years ago

Attachment: kyra1a-gfxglitch1.png added

One second after loading the save

by DrMcCoy, 11 years ago

Attachment: kyra1a-gfxglitch2.png added

After the guy said a line, he's suddenly drawn somewhere else

by DrMcCoy, 11 years ago

Attachment: kyra1a.001 added

Load and watch

comment:1 by lordhoto, 11 years ago

Resolution: fixed
Status: newclosed

comment:2 by lordhoto, 11 years ago

The original did not allow saving in that place, that was not yet implemented in ScummVM. So I added it. This means your savegame is corrupted and it will always suffer from the Herman "jump" glitch.

The other glitch you reported was caused by our code allowing restoration of Brandon's position. I disabled that for now, the original did not support it either.

So all should be fixed now.

comment:3 by lordhoto, 11 years ago

Just for the logs: this happened for *all* Kyrandia 1 versions, not just the Amiga version. Thus I also backported the changes.

comment:4 by lordhoto, 11 years ago

Summary: KYRA: GFX glitch in Amiga version at the bridgeKYRA: GFX glitch at the bridge

comment:5 by lordhoto, 11 years ago

Just for the logs, it seems the original had hard-coded entrance positions for certain scenes. I did implement these now and restored the old code, which saved Brandon's position (and which also was present in the original, at least in the DOS version). All that is revision 44065.

Note: See TracTickets for help on using tickets.