Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4501 closed defect (invalid)

COMI: Crash on using objects in LeChuck's Treasure Room

Reported by: SF/krushr Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

ScummVM: version 0.13.1

Bug Details:
In the second room of the game (LeChuck's Treasure Room), trying to use/look at, pick up or talk to any item will result in a crash stating "Compressed sound 2878 invalid". So far I've only been able to reproduce this bug on Windows 7 RC x64.

Language:
English

Version:
CD

Platform:
Windows 7 Build #7100 x64 using pre-compiled installer.

Ticket imported from: #2830364. Ticket imported from: bugs/4501.

Attachments (2)

scummvm00000.png (105.7 KB ) - added by SF/krushr 10 years ago.
Screencap of the error
comi.s01 (66.0 KB ) - added by SF/krushr 10 years ago.
Save file just before crash occurs

Download all attachments as: .zip

Change History (11)

comment:1 by SF/krushr, 10 years ago

Summary: Crash on using objects in LeChuck's Treasure RoomCOMI: Crash on using objects in LeChuck's Treasure Room

comment:2 by lordhoto, 10 years ago

Did you try copying the game files from your CDs again? It might be that they got corrupted.

Next please give us the exact error message you receive, it should have some tag in braces at the end, which you don't mention in your bug report.

comment:3 by SF/krushr, 10 years ago

Will try copying the data over again.

The stuff at the end in the braces were random characters so I assumed they weren't important, I'll try and grab them next time.

by SF/krushr, 10 years ago

Attachment: scummvm00000.png added

Screencap of the error

by SF/krushr, 10 years ago

Attachment: comi.s01 added

Save file just before crash occurs

comment:4 by SF/krushr, 10 years ago

Tried again after copying the data over again, same error.

I've uploaded a screencap of the error as I'm unsure as to how to reproduce those characters in the brace

comment:5 by SF/krushr, 10 years ago

See screencap attached for more detailed information on the error

comment:6 by eriktorbjorn, 10 years ago

If the file (almost certainly voxdisk1.bun) isn't corrupted, perhaps it's trying to read from the wrong position? Could you try the next daily snapshot build? I've just added some more information to the error message.

(Actually, you could try today's snapshot build to see if you can still reproduce the error, if you like. I'm not aware of any bugfixes that would make any difference, though.)

comment:7 by SF/krushr, 10 years ago

Status: newclosed

comment:8 by SF/krushr, 10 years ago

It seems that my voxdisk1.bun is corrupt, I tried a friend's disk and was unable to reproduce the bug, so it looks like I'll need a new set of disks.

comment:9 by eriktorbjorn, 10 years ago

Resolution: invalid
Note: See TracTickets for help on using tickets.