Opened 11 years ago

Closed 11 years ago

Last modified 22 months ago

#4500 closed defect (wontfix)

VISTA: SDL Audio layer DirectX problem

Reported by: SF/mac_es Owned by: sev-
Priority: normal Component: Port: Win32
Keywords: build Cc:
Game:

Description

I have to assign compatibility mode whith XP SP2 in Vista in order to run SummvmVM.

I have migrated my machine from XP to Vista, and when I migrate my ScummVM enviroment I got a crash...

Windows Vista SP2 Spanish (whith all mandatory updates till now 07/30/09), Intel Quad CPU whith 4GB RAM

Compiled under MSYS 1.0.11, gcc.exe (GCC) 3.4.5 (mingw-vista special r3) from trunk Libraries : FLAC 1.2.1, fluidsynth 1.0.9, libmad-0.15.1b, libogg-1.1.4, libvorbis-1.2.3, nasm-2.06, SDL-1.2.13, zlib-1.2.3

To reproduce it (at least in my machine):

1) Start ScummVM whithout scummvm.ini (it starts ok) 2) Add games (it add them ok, and start them ok) 3) Use options button (global's one) whithout changing anything 4) Exit 5) restart Scummvm, it loads the gui but inmediatly 'ScummVM has stopped responding' crash

What I have found:

If I remove in scummvm.ini the global section it runs again. If I put the compability mode for the exe it runs ok and I can keep the global sectin. It doesn't affect running it whith Administrator rights, it crashes If I run a target directly from commandline it crashes.

It is only me?

Ticket imported from: #2830284. Ticket imported from: bugs/4500.

Change History (9)

comment:1 by SF/mac_es, 11 years ago

Whith this version:

ScummVM 1.1.0svn43024 (Aug 3 2009 16:39:45)

No clue what have changed...

I can go into options and modify them. But if I modify the savepath it crashes, I have tried modifying via:

Edit game -> crashes Environment variable -> crashes

comment:2 by SF/mac_es, 11 years ago

Summary: VISTA: Compatibility modeVISTA: NOT compatible whith gcc 3.4.5 mingw-vista special r3

comment:3 by SF/mac_es, 11 years ago

OK, I have updated gcc to 4.3.3 and the problem its gone...

So the problem is in GCC 3.4.5 (mingw-vista special r3) which is the default gcc (in current and experimental) for mingw right now.

I have had to get 4.3.3 because in 4.4.0 I have a problem whith g++ crashing from configure script...

I change the topic as well.

comment:4 by SF/mac_es, 11 years ago

Summary: VISTA: NOT compatible whith gcc 3.4.5 mingw-vista special r3VISTA: SDL Audio layer DirectX problem

comment:5 by SF/mac_es, 11 years ago

I'm getting the error now randomly... So I debug the 'share exception' and I finally narrowed it to the SDL Audio layer.

If I put SET SDL_AUDIODRIVER=waveout it never crashes, I have tried whith 0.13.1 branch and it doesn't crash

So the workarounds are:

XP Mode compatibility SDL Audio driver waveout

I'm runnging Vista DirectX 10, SoundMax Integrated digital HD Audio 6.10.1.6540

I Update again the title

comment:6 by sev-, 11 years ago

Thus it is not ScummVM, but SDL problem. Closing this.

comment:7 by sev-, 11 years ago

Owner: set to sev-
Resolution: wontfix
Status: newclosed

comment:8 by Strangerke, 7 years ago

Component: --Unset--Ports

comment:9 by digitall, 22 months ago

Component: PortsPort: Win32
Note: See TracTickets for help on using tickets.