Opened 10 years ago

Closed 10 years ago

#4469 closed defect (fixed)

IHNM: Crash after starting the game

Reported by: SF/dhwz Owned by: wjp
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: I Have No Mouth

Description

Scummvm 1.0.0svn42676 on Win32
I Have No Mouth and I Must Scream DOS German

The Game crashes right after starting it.

Here is a debug output:

Looking for a plugin supporting this gameid... Saga engine [all games]
Starting 'SAGA Engine game'
Found game: ihnm ( DOS/German) (17)
... new best match, removing all previous candidates
Running I Have No Mouth and I Must Scream (DOS/German)
Font::loadFont(): Reading fontResourceId 2...
Character width: 7
Character height: 8
Row padding: 188
New row length: 276
Font::loadFont(): Reading fontResourceId 3...
Character width: 16
Character height: 20
Row padding: 312
New row length: 377
Font::loadFont(): Reading fontResourceId 4...
Character width: 7
Character height: 8
Row padding: 160
New row length: 175
Font::loadFont(): Reading fontResourceId 5...
Character width: 6
Character height: 9
Row padding: 190
New row length: 199
Font::loadFont(): Reading fontResourceId 6...
Character width: 6
Character height: 8
Row padding: 128
Invalid index backreference in font char 224!

After this message the application closes.

Ticket imported from: #2826697. Ticket imported from: bugs/4469.

Change History (5)

comment:1 by wjp, 10 years ago

Thanks for the report. I have just made a change to the font loading code that might fix it. Could you try with the next SVN snapshot?

comment:2 by SF/dhwz, 10 years ago

Yes sure, I'll try the next snapshot tomorrow and report if the problem is fixed.

comment:3 by SF/dhwz, 10 years ago

Ok, I've tried the current SVN build. The problem is fixed. Thanks!

comment:4 by SF/dhwz, 10 years ago

Resolution: fixed

comment:5 by sev-, 10 years ago

Owner: set to wjp
Status: newclosed
Note: See TracTickets for help on using tickets.