Opened 10 years ago

Closed 10 years ago

#4468 closed defect (fixed)

DRASCULA: Crash when smashing church window.

Reported by: SF/ezekiel000 Owned by: eriktorbjorn
Priority: blocker Component: Engine: Drascula
Keywords: Cc:
Game: Drascula

Description

ScummVM crashes just after you smash the church window with the pike in the graveyard. The terminal just says segmentation fault.

Running on: Ubuntu 9.04 amd64, ScummVM svn42679, Drascula DOS/English

Ticket imported from: #2826611. Ticket imported from: bugs/4468.

Attachments (1)

save.tar.gz (325 bytes ) - added by SF/ezekiel000 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 by sev-, 10 years ago

please, provide the savegame.

by SF/ezekiel000, 10 years ago

Attachment: save.tar.gz added

comment:2 by sev-, 10 years ago

Priority: normalblocker

comment:3 by sev-, 10 years ago

Raising priority. This is a release-critical bug.

comment:4 by eriktorbjorn, 10 years ago

I couldn't reproduce the crash, but Valgrind reported an error caused by an unterminated string. I've fixed that on the trunk and the branch. Could you check if it fixes the crash for you?

comment:5 by SF/ezekiel000, 10 years ago

That seems to have fixed it, as the next thing to happens after where it used to crash is that Hacker says a line.

comment:6 by eriktorbjorn, 10 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:7 by eriktorbjorn, 10 years ago

Good, I'm closing this one as fixed then.

Note: See TracTickets for help on using tickets.