Opened 18 years ago

Closed 18 years ago

Last modified 23 months ago

#446 closed defect (invalid)

Build fails on Jaguar - Mac OS X 10.2

Reported by: (none) Owned by: fingolfin
Priority: normal Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

The latest CVS snapshot (08-31) fails to build on Mac OS X Jaguar, Version 10.2

Compiler Version: gcc 3.1 (August Developer Tools)

I first built SDL 1.2.4 using ./configure; make; make install and also installed libmad (also configure; make; make install)

I ran a configure without options in scummvm directory, and then make.

* QuickTimeMusic.h and QuickTimeComponents.h were not found; sound/mididrv.o doesn't build.

I modified the makefile to include the path to these headers, and it compiled mididrv.o successfully, but when building the final binary,

* It complained about missing symbols:

ld: Undefined symbols: _AudioOutputUnitStart _AudioOutputUnitStop _AudioUnitInitialize _AudioUnitSetProperty _MusicDeviceMIDIEvent _NADisposeNoteChannel _NANewNoteChannel _NAPlayNote _NASetController _NASetInstrumentNumber _NAStuffToneDescription

Shouldn't we be using SDL for audio output rather than QuickTime? Maybe I'm confused.

Ticket imported from: #602928. Ticket imported from: bugs/446.

Change History (3)

comment:1 by fingolfin, 18 years ago

The problem is that you are doing the build wrong.

First off, the configure script is not doing anything useful, I just started creating it, and it's not used for anything, ignore it.

When you enter make the first time, a file "build.rules" is created, you have to editi it and uncomment the two OS X specific lines, then perform the make (e.g. do a "make clean && make").

comment:2 by fingolfin, 18 years ago

Owner: set to fingolfin
Resolution: invalid
Status: newclosed

comment:3 by digitall, 23 months ago

Component: --Unset--Port: Mac OS X
Note: See TracTickets for help on using tickets.