Opened 17 years ago

Closed 17 years ago

Last modified 10 years ago

#445 closed defect (fixed)

SIMON+Win32: no mouse input

Reported by: SF/zorbid Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

Itr is impossible to pass the copy protection of
Simon1DOS in scummvmgl (Win32). It seems that the
program doesn't notice the mouse click (or the position
of the mouse cursor?)

There are no problems in the standard SDL version.
I'm using the latest build but the problem is not new.

Ticket imported from: #602836. Ticket imported from: bugs/445.

Change History (11)

comment:1 Changed 17 years ago by fingolfin

Component: Engine: AGOS
Game: Simon the Sorcerer 1
Summary: SIMON/ScummVMgl: no mouse inputSIMON+Win32: no mouse input

comment:2 Changed 17 years ago by SF/zorbid

Why did you change the title?
Sorry if I haven't been clear: the problem is specific to
scummvmgl.exe, there is no problem with scummvm.exe.

comment:3 Changed 17 years ago by fingolfin

The title was changed to correspond to our bug naming scheme. It is
understood that your problem only occurs with the SDL_gl. We'll look
into this once the SDL_gl backend is working again (right now only the
SDL backend is functional, all others are pending updates).

comment:4 Changed 17 years ago by SF/zorbid

Resolution: fixed
Status: newclosed

comment:5 Changed 17 years ago by SF/zorbid

It's fixed :)

comment:6 Changed 17 years ago by Kirben

Component: Engine: AGOS
Game: Simon the Sorcerer 1
Status: closednew

comment:7 Changed 17 years ago by Kirben

Status: newclosed

comment:8 Changed 17 years ago by Kirben

Component: Engine: AGOS
Game: Simon the Sorcerer 1

comment:9 Changed 14 years ago by fingolfin

Component: Engine: AGOSEngine: AGI
Game: Simon the Sorcerer 1Space Quest 1

comment:10 Changed 13 years ago by Kirben

Component: Engine: AGIEngine: AGOS
Game: Space Quest 1Simon the Sorcerer 1

comment:11 Changed 10 years ago by Kirben

Owner: set to Kirben
Note: See TracTickets for help on using tickets.