Opened 10 years ago

Closed 10 years ago

#4404 closed defect (fixed)

DW2: disappearing cursor

Reported by: SF/escarlate Owned by: dreammaster
Priority: high Component: Engine: Tinsel
Keywords: script Cc:
Game: Discworld II

Description

The cursor disappears when trying to switch the hammerhead shark for the Bursar's mallet in the garden. The animations keep going, the music keeps playing, but the cursor is nowhere to be seen and the F1 menu doesn't work either. The weird thing is, if you start switching mallets for inventory items with the other characters first, the bug doesn't occur and the game can be completed. This was the only bug I encountered, and after that I completed the game without any other issues using the July 11, 2009 Windows build, on a Windows XP SP2 machine. The game is the (CD/DOS/English) US version. I attached a savegame with all the necessary items inside the luggage.

Ticket imported from: #2820788. Ticket imported from: bugs/4404.

Attachments (1)

dw2-us.002 (2.1 KB ) - added by SF/escarlate 10 years ago.
Discworld 2 garden bug

Download all attachments as: .zip

Change History (6)

by SF/escarlate, 10 years ago

Attachment: dw2-us.002 added

Discworld 2 garden bug

comment:1 by sev-, 10 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:2 by sev-, 10 years ago

Priority: normalhigh

comment:3 by sev-, 10 years ago

Summary: Discworld 2 disappearing cursorDW2: disappearing cursor

comment:4 by dreammaster, 10 years ago

This seems to occur with the GB-English version as well, and I had it occurring even when I swapped the other two mallets first. The problem is that performing the action starts an animation sequence where Rincewind should replace the Burser's mallet at an appropriate exact moment - the problem being that that moment doesn't seem to arrive, so hence it remains in the cut-scene forever. It may be a related issue that the Burser doesn't actually 'swing' the mallet anymore once the 'cut-scene' starts.

I'll have a look into this and see if I can figure out what's going on.

comment:5 by dreammaster, 10 years ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.