Opened 10 years ago

Closed 10 years ago

#4382 closed defect (fixed)

DC: Bargon Attack, virtual keyboard non-responsive

Reported by: SF/threepoint Owned by: zeldin
Priority: high Component: Engine: Gob
Keywords: Cc:
Game: Bargon Attack

Description

ScummVM info:
Build 0.13.1, Dreamcast.
Bargon Attack, DOS.

After starting Bargon Attack the GAME/DEMO screen will load, which at that time you have to press F1 for the GAME or F2 for the DEMO.
The problem is that the virtual keyboard will not start after prssing the DC's left trigger button, preventing the game from being played.

I do have a DC keyboard. It's F1 key does work correctly, allowing me to play the game.

The virtual keyboard is a non-issue with the Win32 version, so it plays just fine in that.

Ticket imported from: #2813727. Ticket imported from: bugs/4382.

Change History (11)

comment:1 by jvprat, 10 years ago

Owner: set to zeldin

comment:2 by zeldin, 10 years ago

I don't have this game, so I can't verify, but it sounds like the problem is that the game waits for keyboard input without calling updateScreen(). Since the screen is not updated, you will not see the virtual keyboard appear, nor will you see the mouse pointer move. Thus, using the virtual keyboard becomes very difficult.

I've made a tentative fix for this case, If you have the possibility to test with the next
nightly build, that would be great.

comment:3 by zeldin, 10 years ago

Resolution: fixed

comment:4 by sev-, 10 years ago

Raising priority. This bug is nice to get fixed before the release.

comment:5 by sev-, 10 years ago

Priority: normalhigh

comment:6 by zeldin, 10 years ago

We're waiting for feedback from the original poster whether the implemented
fix solves his problem. I don't see how modifying the priority is going to make
much difference...

comment:7 by sev-, 10 years ago

As you probably know, I do it always before the release in order to keep track of the bugs. See my e-mail to -devel soon

comment:8 by fingolfin, 10 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:9 by fingolfin, 10 years ago

Status: newpending

comment:10 by SF/sf-robot, 10 years ago

Status: pendingclosed

comment:11 by SF/sf-robot, 10 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.